Can't place Fish Trap

Online official

I cannot place a fish trap in a pond. If I try to place a trap in the input, then the game says “you need to place it in the water.” But I’m already clinking into the water. If I try to place on the edge of the water where there is no red cross, then nothing happens.

Hey ASmir,

Could you look if the number of fish traps in your inventory goes down when placing it where there is no red cross? You may need to move the item around in your inventory to see the number change.
(Also, make sure the projection is still visible before placing the item. Though I’m not sure if this is possible, you might be trying to place it under the mesh.)

I have changed the title of this thread to be more descriptive. Your thread will be seen regardless.

Nothing happens. I try to set a trap where there is no red cross, but nothing happens. No messages, nothing

I assume you’ve tried standing and aiming further into the water, looking in all directions, going a bunch of different places, maybe even crouching?

Btw, is this in the Exiled Lands, Isle of Siptah or both? Could you also test this on other servers and single-player, if possible?

This issue is related to Isle of Siptah - Fish Traps bugged

This happens in the exiled lands on at least 2 servers. I tried to set traps along the river from the Black Galleon to the South Aqueduct, and only in one place along the entire river did I manage to set them

I can’t place mine either. I’ve tried Shift, ALT, CTRL, mousewheel, you name it. This ain’t my 9th rodeo. They’ve always been tetchy, but this goes beyond the norm.

Hey @ASmir

Thanks for your feedback, we’ve relayed it to our team so they can look into it.


I am having the same issue in the river in D10 on the exiles map. I can place a shell fish trap but the regular fish trap will not place. It gives the red X and error saying the trap must be in water, but even completely submerged its the same error. I have tried for the length of the river in this section without luck.

I have a picture but it will not allow me to paste it into the forum.

I am unable to place either trap in the river running by the Unnamed City on the Exiles map. I found one small spot they can be placed in G6 and I saw some traps someone had placed in E5 but they have since de-spawned and I am unable to place traps there. I have tried rotating, raising and lowering, tilting, placing foundations underneath and everything says “must be placed in water”, “overlapping with another object or terrain”, or “not enough contact with ground”. The change to the fish traps with the update was horrible in and of itself, making oil one of the most difficult resources to obtain, but to have almost no locations they can be placed outside of Noob River or the ocean in the east is just ridiculous.

Of my 2 fish houses, one is years old. The Mrs took the fish traps up, because we have 6 cupboards full now.
Now that we want to put them back in…So sorry, they will no go back in the house they came out of.

I built a fish house last week, The traps did not go in. So I put them on the shore, almost all the way out of the water, then they worked. I had to tear down my fish house and build it around the traps on the shore.

There is never enough time to do things right the first time…
There is always time to do it over again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.