Cant see the Patches

I cant see the patches any were for CONAN UNDEFEATED

Can someone please send me a link as im very tired keep doing wave 25 and can advance

i would be very great full im not a tech im old

thanks SlowTrain

Hello @slowtrain, welcome to the community!

You may find patch notes here:

And also in the Steam pages:

Are you running into any sort of issue? Could you please elaborate?

Hi thanks for a reply well im playing the game or was got to the black colloses completed it 9 times now and it wont advance me to next game im stuck there i keep seing talk about patches but for the life of me i cant see any links to up date my game so its still broken

ill just add i brought my game from Steam as soonas it came out i also brought a new super computa to play the game with i have seen patch notes saying theres a glitch in moving on to the next game and thats my problem no matter how many times i do the game and win it says only try again this is at the end of level 3
i hope thats clearer for you
cheers anthoney

A full overview of Patch Notes may be found on the wiki:

Edit: Updated and styled the version history further.

Hi its not the Notes i need its the acual Patches reading about it dont make my game work ??

but thanks i have read all the links re patch but no patch ?

I also can’t find a patch that says they fixed this.

With “black colossus” do you mean a boss (Prince Kutamun, Thugra Khotan?), or an achievement…?
With “level 3”, are you referring to wave 3 or the third map in the scenario mode?

Anyways, could you try rephrasing your bug report as clear as possible in a single comment? This might help clarify things for the developers.

I can understand that after defeating a game (your chosen amount of waves) you only get the option to retry and not quit the game? Have you tried pressing the (ESC) Escape or Enter button to go back to the main menu? You should also simply be able to restart your game.

yes your right first time its the end of the boss guy in level 3 when i completed it killed the boss it said vic and that ive opened level 1v and it dint high light the next battle just try again
Damn killing 25 levels on hard is bad enought but ive tryed it 10 times now with the same result

so many posts re my problem but all re the patch i dont seem to find lol

could you link those posts?

Well ive now Played the Beta up to the end of V and that too wont go to 1V
so i ges its not even fixed in Beta yet

damn slowtrain

As you own the game on Steam, it should be updated automatically by the Steam client.

Your can confirm that your game is up-to-date by checking the bottom right area of the main menu, it should show the following information:

Regarding the reported issue, there are in fact 5 missions currently available so this is expected and not an issue.

More content will be available in the near future so stay tuned!

You said that it stated “You have opened level VI” (or “level 6”)?
If it does say that, it shouldn’t do so while there are only 5 levels, that would be confusing.

re read i said 1V not 6


…I don’t know why a level should be called 1V though (I don’t play CU btw) :man_shrugging: