Can't start match with Valeria

If I try to start a game with Valeria as my hero, I get stuck at loading screen, the sword progressbar fills normally, but match never starts.

No problem when picking Conan though.

2 Likes

Hey @deadbeforedishonored

Which settings did you select when starting the map?

No custom settings applied, I’m trying to play the campaign on default settings.

1 Like

Thanks for the clarification. The devs will look into it.
Apologies for the frustration.

I’ve tried deleting the savefiles in the steam directory, i’ve tried reinstalling with firewall and antivirus off and nothing, getting the exact same results.

Tried the steam file revalidation, and nothing, game’s still malfunctioning.

Same problem here.

This is a big problem, is not just that I can’t pick Valeria as my hero, the game is simply unable to start a match if Valeria is in it, so I can’t play Co-Op unless my partner owns the DLC hero. I need this fixed soon.

Any word from the devs?

1 Like

Hey @deadbeforedishonored,

Starting to look into this now, which of the scenario maps where you attempting to enter? Was it more than one? Did you change the difficulty for the scenario?

I’ve tried campaign scenarios 1, 2 and 3 on both difficulties, I also tried multiplayer, challenges, and custom solo match, nothing works. I can only play default Conan. I purchased deluxe to see if the 3rd hero had the same problem and he does, King Conan skin is also broken.

If I try to play a match with any hero other than Conan with default skin, the game gets stuck at loading screen, the sword bar fills, the ambient sounds begin to play, but the loading screen stays and the match does not start.

Co-op is completely impossible since the game can only process default Conan and he can’t be picked by both players.

1 Like

Sorry for the inconvenience @deadbeforedishonored, but I’m going to need some more info in order to diagnose this better.

  • What language are you playing the game on?
  • Have you ever actually crashed? (Usually you would receive a crash dialogue and a mention of “uploading”).

could you please send:

  • dxdiag report (allows us to see if there might be some some specific piece of hardware causing the issue)
  • Steam Name (Allows us to search for any crash data)

You can either email at support@petroglyphgames.com OR meet me over at the official Discord #bugs-reporting https://discord.gg/9qKZbTf (9am - 6pm Pacific time) and talk to me directly.

Also, @FractalizeR do you have the exact same issue as described by @deadbeforedishonored?

I am playing the game in english. My steam name is knightcommander1, and I haven’t had any crashes, had to alt+f4 everytime.

I have emailed a dxdiag report to you, and joined the discord and left a message at #bugs.

are there any solutions already?
Same Problem here … :sweat:

Hey guys,

The most recent patch aims to fix this:

  • Give it a try and let us know if you still have some issues!
    Note what we did find from those that submitted reports and provided Dxdiag of their machines, showed that they were playing well below the machine min specs for this game which was part of the problem.