Can't use tools or weapons


#1

Help us help you - please be as descriptive as possible. Please use this template for bug reports.


Game mode: Singleplayer
Problem: Bug

When starting a new single player/coop server, I’m able to use my hands for combat just fine. Once I equip a tool or weapon, my character just holds it in its right hand but I can’t swing or attack or use it at all. I also cannot unequip it unless I climb or eat something. I’ve tried taking off all mods, restarting server and even dying. Nothing seems to work and has made the game unplayable for me. Anyone know why this is happening or know a fix?


#2

I’m experiencing the same problem, just without the climbing and eating part, a fix would be amazing cuz i cant play the game at all. cant use tools to get resources and cant use weapons to defend in-game. No point in playing the game if you cant do that. bug fix needs to come asap


#3

I am having the same problem. Happened earlier today. I recreated character. That fixed. It just happened again. I have tried all the inventory swap things. I can swap anything from inv to radial menu except my iron pickaxe. It is in left slot. It gives message unable to remove item. I also cannot remove items from radial menu by swapping with empty slot. I will not be playing this game until this is fixed. Needs to at least be a fix that doesn’t reset character progress.


#4

Just a little remind. You have to be in idle mode. If you wield item (is shown on your avatar), you cannot move them from quickbar


#5