ClientPatcher.exe fails to do anything

I have re-installed the game fully, run everything as admin, let the .exe run for hours upon hours, and nothing.

Whatever method I use, it ends up the same: ClientPatcher.exe *32 uses a set amount of my CPU and RAM, but does nothing.

I have played the game before, quite a bit. This started in November last year, IIRC, and I’ve tried launching the game every few weeks since then. Now, finally, my itch to play SWL has overpowered my laziness, and I ask for help.

Using Steam, Windows 7 64-bit.

The logs:

Patcher.log

[2020-04-30 11:04:56Z #0] [ID:0] [Main] Patcher exe hash is 648fbd5ee6145652b09cccc15448ebfe
[2020-04-30 11:04:56Z #0] [ID:0] [Patcher] Patch server nslookup (exitcode: 0)
Non-authoritative answer:

Server: mydevice
Address: 192.168.1.254

Name: cds.q4s5f2v4.hwcdn dot net
Addresses: 69.16.175.42
69.16.175.10
Aliases: update.secretworld dot com

[2020-04-30 11:04:57Z #0] [ID:0] [ResourceManager] RDB files in use: 11
[2020-04-30 11:04:57Z #0] [ID:0] [ResourceManager] Found 1091.2 MB Unused space in all rdbdata files. 0 errors.
[2020-04-30 11:04:57Z #0] [ID:0] [ResourceManager] No project defined,you are missing the project configuration keys or they are pointing to a non existing project,running dreamworld control center and selecting a project should fix it

ClientLog.txt

[2020-04-30 10:53:36Z #0] [ID:0] IMPORTANT: Steam - Steam API initialized successfully
[2020-04-30 10:53:36Z #0] [ID:0] IMPORTANT: Main - Universe is a live universe
[2020-04-30 10:53:36Z #0] [ID:0] ERROR: Main - Invalid clienthash arg
[2020-04-30 10:53:36Z #0] [ID:0] ERROR: Main - Invalid patcher key arg

I’d contact funcom’s tech support, but they don’t seem to want that; imgur dot com/pTgI3Bj

(Note: not allowed links in my posts, so changed links to dot com)

Can’t see on that image where you are actually at, but I send a tricket from here https://funcom.com/help without issues two days ago.

To where? When you use the drop-down menu and select SWL -> Tech they just show you the forums. They allow you to message them for account/billing and questions, but not for tech support.

Yup, the tech dropdown menu just sends people here, it has for a long time now. You could try posing it as a question, but I don’t know if you’d have any luck or not.

99% chance they’d tell me to post my issue here.

If you select “Tech” from the middle drop down, the whole form goes away. They don’t want your tech issues. I’d just submit it as a Question.

I did. No reply. I even messaged them on twitter.

1 Like

What other programs do you have running in the background? Can you try running it as admin?

Is it worth trying what @ValkyrLee suggests in this thread?


Sounds like your problem is a real stumper :frowning:

Tried that, yes. Tried all the .exe files as admin, not admin, with a fresh install, steam install, non-steam install, various compatability modes, etc.

As for the programs, I tried disabling all that could be safely disabled. Fresh restart (multiple times), not launching anything else, and nothing running other than steam, and the few windows files that need to run.

I’ve even changed the CPU and GPU, and even went with a different GPU manufacturer.

Done all that’s possible there, except for the awesomium process bit. But since the game won’t even get as far as to start patching, I’m not going to install it again just to try that.

1 Like

Maybe @AndyB can help with that. This problem is odd because according to the logs it almost sounds like the patcher is trying to download a dev version of the game which of course you are denied access to. Were you in any beta or TestLive groups at any point? Try making sure that you are opted out of betas for the game through Steam… It’s a long shot, but can’t hurt.