ClientPatcher.exe *32 hangs, no window opens, Win 7 "professional" 64 bit

After a hiatus following the conversion of the game I purchased (TSW) to what is now marketed as “TSWL”, I tried to start my old TSW installation but it seemed to do nothing. No window opened, no hdd activity, no feedback at all. So I checked the running tasks and found ClientPatcher.exe *32 running at 17% CPU. Killing it and restarting didn’t make any difference.

So then I uninstalled the game and downloaded the installer anew, but that gave the exact same issue; the launcher was installed but won’t actually show up or do something useful, sitting at 17% CPU untill killed manually.

Since the TSW and the TSWL patchers are essentially the same, I tried starting TSWL, which also happened to be on my system due to the initial issues with the relaunch.

This, too, spawns “ClientPatcher.exe *32” and leaves it sitting at 17% CPU, albeit with a 4 times larger memory footprint.

Then I read about directX apparently not being launched by the standalone installer, and went to use the steam install.

Guess what… after downloading all the data, it would ALSO spawn “ClientPatcher.exe *32”, sitting at the same 17% CPU and the same memory footprint as the standalone TSWL installer.

I ran dxdiag 32 bit and 64 bit, no errors reported. I have absolutely no issues with other games, so directx clearly is working.

I then ran dxwebsetup.exe from the installation folder as suggested by the other post, which proudly told me that a newer version of directx was installed and that no action needed to be performed (which is both correct and expected). That did, however, not change the problem at hand at all.

What I did change between back then and nowadays is the graphics card. It however uses the same driver as the previous one (radeon unified driver), has the same specs and, again, no other game even cared about the change. Even other Funcom games run perfectly fine, like Conan Exiles.

So… how do I get the launcher to tell me what the hell the problem is? Why can’t you gaming companies produce software that will tell the user what the problem is anymore? Why am I being kept in the dark about issues that very likely are easily fixed by myself without causing endless support tickets if only I was given the information needed to do so by the software causing the problems in the first place?

Obviously, the launcher is waiting for something, but for what? A connection to the internet (why bother until the main window is created and shown)? A driver to be loaded (why not time out gracefully after a sensible time like 30 seconds and then tell me what the problem is)? Some other condition to be met (again, why not pop up a standard dialog box informing me about the requirement)?

So, now I am here, asking you to guess and tell me what the software definitely knows but refuses to tell me…

First of all, there’s TSW and there’s SWL, TSWL isn’t a thing.

You said that you’ve downloaded a fresh install, did that install complete? Am I right in thinking that you’re not getting the launcher window, just the process? Did you try any of the other game exe files? They should all end up running the same thing, just checking.
What GFX card is it?
You said you launched the steam client, was that a fresh install? How long was ClientPatcher.exe hanging for?

It’s possible that there’s a new version of the patcher to DL, which is why it’s not bringing up the main window, though why it’s not downloading properly is a conundrum.

1 Like

First I assume as per your post you haven’t updated drivers.

Second that you have ONLY “Secret World Legends” under your steamapps folder.

Try the Funcom support process outlined here. In your case the relevant part should be launching the patcher clean with admin rights:

Thanks for the replies, I will answer your questions first (TL:DR: look for the new insights at “HOWEVER”):

The fresh install “completed” in that steam downloaded about 15GB and then tried to actually launch it, which resulted in the same hanging .exe as the others.

I did also try the “TheSecretWorldDX11.exe”, which also spawned the hanging .exe as above.

The GPU is reported as “AMD Radeon R7 200 Series”.

The steam install was a completely fresh one, as I try to avoid Steam (or any other DRM platform for that matter, as they create lock-in effects and milk private data) if at all possible, which in case of (T)SW(L) used to be possible.

The .exe has been hanging for various times until I killed it manually; I left it hanging for 2 hours just to be sure, no joy.

My graphics drivers should be current, because the card is rather ancient and although the “Radeon unified driver” installer does occasionally get a version bump, that actually are only updates the much newer cards, the older ones didn’t get an update in years, likely never will. Also, Windows claims it to be current.

I have also tried the suggestions from the linked post. However, the main part, the “PatcherSetup.exe” is not in the installation folder, because, except for the steam client, since the launcher doesn’t launch, it has not downloaded anything. I tried to remove the appropriate folders anyway, and after starting the launcher they were recreated, but completely empty. Thus, after verifying that it still did not work, I moved the old folders back into place.

HOWEVER: the launcher DID open yesterday, way after I posted this (at about 5AM or somesuch). ALL launchers did: the steam one, the SWL standalone one and the TSW one. TSW was downloading, but I had to stop it, expecting it to work since then. Then today afternoon they again failed to launch, with the steam client actually posting an error dialog (only once, regardless of how often I started it) about Directx not initializing. I gave up at that time and tried it at about 1AM again, and sure enough, all launchers would work again.

So obviously it is an issue with the current time. But WTF? Is it possible there is a problem with the stupid DST we are forced to use? If so, that issue obviously has crept up after the relaunch, and also does not explain why it works during nighttime, which is way more than the single DST hour.

To test, I stopped it now, after downloading several GB, and again it started just fine. The SWL launcher also launched normally, but I didn’t let it install. TSW is now happily patching it’s resource database (4/4), halfway through 8GB. I absolutely expect it to again fail to start in the afternoon.

So obviously the directx error message is false, and also neither the hardware, drivers nor the OS, nor port forwarding, connection or anything other is the problem. My system time is set to our local time and is reasonably correct.

IOW: W. T. F. ?


Yup, that’s confusing as hell and sucks big time! I’ve not heard of a time related bug like this before, though it’s possible that correlation does not mean causation.

Since you got the launchers open, did that install PatcherSetup.exe?

Why you are stopping the patching processes? I would allow them to finish then run the PatcherSetup.exe (not ClientPatcher.exe) as per the Funcom Support email link I sent you as Admin to repair any files corrupted during the download.

The graphics drivers might be a problem if you are using NVIDIA (which you are not) OR any latest drivers updated this year. Updated drivers are known to cause problems. Regardless of how old your GPU is. Not saying this is your problem, but you should be aware your assumption that latest driver for old GPU = stable SWL is wrong.

The network should not be a problem. OS should not be a problem.

Also, have you contacted Funcom support? I’m fairly certain they have a standard response to this which might be different from the one in the link I posted. There might be one more file you need to delete.

No, it did not install PatcherSetup.exe anywhere under the TSW folder tree. Maybe that is an SWL thing? I only let TSW install and didn’t want to download an additional 30GB for SWL.

I stopped the patcher to see if it would reliably launch, and also because I did not have the time to sit through the entire download in one go.
I also rebooted the system during the patching to see if that would stop the patcher from launching, but it reliably launches after about 0:20 AM. I tried it at about 0:15AM and that did not yet launch, at 0:22AM it did.

When it was fully patched I could enter the game and my chars were where I last left them and everything worked ingame as it should.

Then in the afternoon, as expected, it failed, until, as mentioned above, 0:22, when it would start to work again.

I have just finished repairing the RDB, just in case. Since it launches fine ATM, I can only test if it helped this afternoon. Likely not, because the installer itself did not launch, which would be needed for any RDB to be installed in the first place.

Unless Windows update has installed a driver update for the GPU, I don’t think I updated it this year. Possibly last year, though I think not. The device info says the driver is from 2014-11-20, version 14.501.1003.0.

I have not contacted funcom support, as I was expecting them to be present in their own support forum? The info text at least seems to suggest that, guess I was mislead by that. :frowning:

For good measure, I tried playing with the system time, setting it to different times PM and AM, even changing the display format of the time to 12hour, no change. Neither did it start when artificially set to AM, nor did it not start when artificially set to PM.

The patcher itself seems to be using UTC-1, because even though the Patcher.log file’s date is the current time (0:49, 05-31), the latest entry is logged at 22:47, 05-30.

The failing steam SWL patcher log stops after

[ID:0] [ResourceManager] No project defined,you are missing the project configuration keys or they are pointing to a non existing project,running dreamworld control center and selecting a project should fix it

The working TSW patcher continues there

[ID:0] [ResourceManager] No project defined,you are missing the project configuration keys or they are pointing to a non existing project,running dreamworld control center and selecting a project should fix it [2019-05-30 23:06:02Z #0] [ID:0] [HTTPManager] Downloaded 'H:\SPIELE\The Secret World\LocalConfig.xml' [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] LocalConfig.xml: [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <Config> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <Self> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <ConfigKey>Universe/Client/</ConfigKey> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] </Self> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <Universe> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <Client> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <ClientFileName>TheSecretWorld.exe</ClientFileName> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <ClientFileNameDX11>TheSecretWorldDX11.exe</ClientFileNameDX11> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <HttpPatchFolder>TSWLiveSteam</HttpPatchFolder> [2019-05-30 23:06:02Z #0] [ID:0] [LogLocalConfig] <HttpPatchAddr></HttpPatchAddr>(remaining log entries truncated for brevity)

As you can see, this is a german system, but the TSW language is set to english. I don’t think that mine is the only such configuration, though, so that issue surely would have crept up before if that were connected.

This forum’s more of a community support thing, so that if there’s a fix which has helped out someone before we can share it.

From the sound of it, you need to email support via
They’ve got a lot more technical specifics and troubleshooting stuff than we do, and hopefully will be able to help you!

OK, I solved it. It is an incompatibility with another program that I use regularly - Mumble. If the Mumble client is started before the patcher, the patcher won’t start. Once the patcher is running, the Mumble client has no detriemntal effect.

The timing thing was a coincidence, as I usually (though not always, otherwise I’d probably never have known) start Mumble before anything else, and shut it down at around - you guessed it - midnight.

Now I can file a ticket and hope they can verify that, because others I know do not have that issue. -.-

1 Like

Good detective work! Hopefully that’ll fix it all for you :smiley:

Has anyone discovered any other programs that do this? Exact same issue, yet I don’t use Mumble.