Problems with settings and preferences in games - they aren't being remembered ever since the sever restart


I tried to gain help in game but was told I needed to come to the forum.

The problem is that ever since the restart the following in game issues have occurred every single time I launch the game:

  • I have to re-add all the chat boxes
  • Inventory is all over the place and never in the order I place it. Very disorganized. At first it looked like a drunk squirrel put it together. Now, the squirrel is only partial drunk, but, still needs to sober up.
  • Map of location is always massive .
  • Last character used is never selected (it use to be) now it’s the to character on my list.
  • When I go to the activity finder, it no longer recalls my preferred roles. It used to.

While I’m here, I might as well tell you too, and this was happening prior to the server restart, if a group votes to retreat out of NYR - my game will crash. Sometimes in dungeons too but mostly NYR.

Help would be appreciated as I’d much rather spend time playing the game than fixing the settings each time.

About the game forgetting your settings. Any chance you are using mods like Fashionista or Boo Builder … or similar mods that store resets. Too many presets can in some cases cause the game to be like “too many balls to juggle” and just drop them all on the floor.

As for the NYR crashing. Some people seem to have this. Some under very specific conditions, others always, some never. Not sure if any suggestions exist for lessening the crashes, and since not all have the issue, it prolly depends on something on the individual players machine, which make it near impossible to nail down for a fix.

Since yours sound like it happens on a retreat, it might be hard to actually avoid. Others that for instance crash if they leave through the well, can teleport to leave, or leave through the Activity Finder as ways to not crash. A retreat, thats hard. Even if you could leave before the retreat goes through, you would be stuck with a deserter =/.

1 Like

NYR crash or freeze (in my case) can happen on retreat, on teleport or leave through AF. It is random and I didn’t see any reasonable solution for that except ‘I sneezed and didn’t crash after that’.
About settings. They are stored in /users/username/appdata/local/funcom (that’s for Win7). I would try check if files there are not read-only or tried to launch game as admin.

1 Like

SinOfTheWolfs - I didn’t even think of that. The only Mod I have running is Effects UI. When I come home from work tonight I’ll remove it and see if that fixes it. Thank you.

NYR - yeah :frowning: But hey I’ve never tried leaving through the activity finder. Worth a shot. Thankfully I’m not in a group that retreats too often - that would be painful!

CrimsonRabbit - Thank you. I’ll check the files tonight too and see what happens. Currently on windows 7 - holding on for dear life but I know it’s safer life is only a few more months. Not looking forward to that nightmare.

Thank you both very much for the help. I’ll report back tonight. :grinning:

Hmm i dunno if Effects UI would cause trouble, but it is saving some presets of a sort, so it could be. I used to have one character that occationally lost her UI, chat, Fashionista and boobuilder. Somebody suggested it might be too many presets saved to the two mods. I havent had an issue since deleting boobuilder period. I still use Fashionista, but have fewer presets, if just for the time being.

1 Like

Here is an email from Funcom support I saved for myself. It was for TSW but should work for SWL also:



Thank you for contacting Funcom Support. This may be caused by a corrupted or invalid preferences or GUI file. To ensure this is not the case, I would like to have you reset your The Secret World preferences and reinstall the GUI straight from the server:

  1. Open Windows Explorer

  2. In the address/location bar, enter %LOCALAPPDATA%

  3. Navigate into Funcom\SWL (changed directory to SWL from original email)

  4. Rename the Prefs folder into Prefs_old

  5. Temporarily disable your anti-virus and go to your Secret World install folder

  6. Under Data is a folder called “GUI”. Please delete this

  7. In your Secret World install folder right click on PatcherSetup.exe and run it as an administrator.

  8. When that completes please run the patcher normally.

  9. Locate and open the options menu

  10. Select “Repair broken game data”

  11. Allow the launcher to replace/correct any needed files/information

Please let us know if you continue to have trouble after doing this.


Firstly, thank you again everyone for the help. It was / is truly appreciated.

SinOfTheWolfs and CrimsonRabbit - tried a few things.

  • Killed off Effects UI - no change. Removed it from the folder completely - no change.
  • Ran as admin - No change
  • Killed off Twitch completely - no change.

So I went to the more “oh dear lord” option and…

sturmhaven - you’re email is still valid - even now. Very glad you kept it! That seems to have worked.

The drunk Squirrel is now sober!

Thank you all again. XOXOXOX

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.