Conan Exile Server Browser Issue

No. If that’s the case, then it’s not the port conflict issue I read about. I apologize if I misunderstood what was going on :slight_smile:

Can you tell me what server it is? I can use the server browser in BUGLE to check if it displays the correct values. If it doesn’t, then it’s not the in-game browser that’s bad, but you actually have a problem that needs to be solved.

So the full server name is as follows:

[ZA] The Average Gamers - AOC+BetterThralls

I was just looking at BUGLE and was gonna try it out after dinner to see if it works, let me know if it shows your side :slight_smile:

Mine is just showing ??? for latency and players in BUGLE

Yep, mine too. That means that it’s not getting a reply from port 7778. That most likely means that your server isn’t getting the ping request.

I chose to display “???” for ping rather than 9999, because I think 9999 is misleading.

It is so werid, let me double check the screenshot my mate sent me of the ports on his router, i have also opened all the ports on Firewall my side with the RDP access to the server.

I’m trying to connect to the server now, but it’s stuck at “Attempting to join game” screen:
image

I’ll try direct connect next.

Direct connect works 100s, we all play on the server through direct connect. Loads just fine. Only Server Browser that is giving me issues

What IP address do you use for direct connect? I’m using the one that’s reported by the server directory (20.20.20.254) and it’s not working. Come to think of it, an IP ending in .254 is a bit weird. Are you sure your server is announcing the correct IP?

So we use the Public network IP: 41.193.252.118

The 20.20… IP is the internal one on the network adapater.

Ive now enabled Multihome on the server manager and set the public IP in there. Hoping this works, just want to give it a few minutes to see if it updates.

So using multihome and setting Public IP just puts the server in a crash/retstart loop

[2023.07.14-18.21.28:481][  0]LogServerStats:Error: ServerStatReporter: Failed to find address and port, NetDriver is null
[2023.07.14-18.21.28:481][  0]LogServerStats:Warning: Server stat startup report: No named session was found
[2023.07.14-18.21.28:481][  0]LogServerStats: Startup report. StartupTime=71 Name=[ZA] The Average Gamers - AOC+BetterThralls Map=The Exiled Lands QueryPort=0 Type=1 Region=0 MaxPlayers=0
[2023.07.14-18.21.28:482][  0]FUdpSocketBuilder: Failed to bind SourceServerQueries to 41.193.252.118:27016
[2023.07.14-18.21.28:482][  0]FUdpSocketBuilder: Failed to configure multicast for SourceServerQueries (loopback: 0, ttl: 1)
[2023.07.14-18.21.28:482][  0]FUdpSocketBuilder: Failed to create and initialize socket SourceServerQueries (last error: 0)

Taking multihome setting off now and server stays up but back to having the browser issue

Okay, I downloaded the dedicated server launcher and now I’m trying to figure this out for myself. Apparently, the multihome setting forces the server to try to bind the specified port on the specified IP. You can’t bind on public IP, so multihome won’t work.

What does “External IP” field say in your dedicated server launcher?

here is a screenshot of my network config side for the server.
Ignore the red light on the web page it actually works.

Weird. The server should be reporting that external IP to the directory, not the internal one. You should probably post a question on the dedicated server launcher topic or maybe ask on Conan Exiles Discord. I don’t know what to do about this, since I’ve never hosted my own server before. Sorry I couldn’t help more :frowning:

Dude thanks so much for the help and assistance.

We have been thinking its been a port issue this whole time, but with BUGLE now we could actually see the IP address thats showing in the browsers. So we have narrowed the issue down now thanks to you.

1 Like

Glad I could do something, at least :smiley:

1 Like

Hey, I noticed it’s solved now. Mind sharing how you fixed it? :smiley:

Yeah we were sitting up all night looking into it.

My friend has a Mikrotik router and obviously has some network settings up and one of them wasnt done right. So his router and IP he assigned to my connection for my dedicated box in his home network had some issue. Which never affected any other game one bit only Conan.

So he removed all my settings and put it on his main network and it just ran. He is in the process of redoing his whole network setup and rules etc now to do it properly.

Ill try get a proper explanation from him and share it with you. Im not that clued up on Network Configs, so this probably doesnt make sense.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.