Control settings doesn't save


#1

Hi,

I’m having problem that everytime I start game my controls are on default. I need to remap everytime.

Where settings are saved?

Windows 10, Steam client.


Character selection in Saga Server
#2

Heya! Our tech specialist should be able to help you. :slight_smile:
Go on over here:
http://help.funcom.com/

Explain the issue and set the dropdown to “tech”. Click on “submit”; you may have to click it twice for it to fully submit. But as long as you get a confirmation ticket number on the following page you’re good to go!


#3

Or…what about using the tips and workarounds the community put together in a 111 hundret post long thread, starting in 2013, that includes every possible solution and even a little tool a player wrote to help with this issue?

Which is actually a long known bug, that the “tech support” has not been able to fix, and refuses to assist with, since…well, 2013 at least (if the old old forum would still be online we could track this issue down to 2008 I bet).

[Andy Edit: Removing unnecessary commentary]

TheChosenOne, here is the link to the thread in the old forum. You will find several workarounds, the one that works for most of the people is in post 40.
https://forums.ageofconan.com/showthread.php?180602-Options-not-saving-Possible-Fix-in-Post-40


#4

It was not always an issue. This problem came about when Funcom decided to start saving preference files on the server side too. They then used their server versions as the primary settings that override your local files each time you start the game.

This bug really should be an easy fix in many ways (stop saving server side, remove size limits causing them to fail to save server side, etc.), but Funcom apparently doesn’t care.

For reference, this is the thread (https://forums.ageofconan.com/showthread.php?180602-Options-not-saving-Possible-Fix-in-Post-40).

There are many work-arounds posted in that thread, some may work, others may not. A lot of failures may be due to user error.

Here is a brief Explanation of things:

The cause of the problem is usually (probably always) the fault of saved chat history. Once that becomes too large, settings won’t be saved server-side when you quit, and thus you keep getting a reload of the old settings each time you play again.

What I do is the manual method for what that program in Post 40 of that thread does.

Prefs are saved here in windows 10:
C:\Users\YOURNAME\AppData\Local\Funcom\Conan\Prefs…

The problem files are per character and named “Windows.xml”.

To fix, you remove the chat history and set the files to read-only. Then, when in-game on the character you are trying to save settings for, you log out to character select and log back in to force an update to server side with a file that actually saves. Then, without talking in chat, remove the read-only flag, change your settings, log out and the new settings should update server-side.

Chat history in these files looks like:

                <Archive name="input_history">
                    <Array name="cursor_pos">
                        <Int32 value="60" />
                        <Int32 value="5" />
                    </Array>
                    <Array name="text">
                        <String value='&quot;/camp&quot;' />
                    </Array>
                </Archive>

replace all occurences of the input_history archive with:

<Archive name="input_history" />

I have done these steps many times when I needed to change settings and it always works for me when done correctly.


#5

Funcom, that’s what you have to fix. Next patch i hope :stuck_out_tongue:


#6

That’s an old bug that’s been around since the game started. The trick most of us have used at one time or another is to set them how you want them and then log off inside an instance like a dungeon, tavern etc… For some reason this fixes the problem 99% of the time.


#7

I am only having this issue with one out of 15 chars… my workaround has been to set its files as read only. Thus removing the chance of serves side files to overwrite my local settings:

Log in to the character and make changes as you’d like, then go to the following location:
%localappdata%\funcom\conan\prefs\ -> YourAccountName
and find which folder is your current character, by looking at the folders called Charxxxxxx’s ‘Date modified’:

Change the folder+files to Read Only, then log out of the character/restart the game to see if that helped.


#8

Same problem for years and years, and all of the above point to the forums and tech solutions which all work. What has worked for me:
Get all of your settings placed where you like them in your personal sweet spot, then zone into The Reliquary, or a dungeon that you can become quickly “Bound to this Instance”, and log out.

I’m constantly changing my layout, and this is the quickest way to save changes.

Hope this helps.

Rock On


#9

This is something that has always puzzled me as to what is really going on with Funcom’s Servers and settings. I have never tried this method myself, but it honestly doesn’t make sense with the theory that too-large chat logs break the settings saving. Binding to an instance should have no effect on chat log size and thus, not allow your settings to save. But for some unknown reason, it seems to work.

A theory I just now came up with is that maybe, when settings are saved, the Server also saves a lot of playfield information. So the Large Playfield + large chat log together fail to save, but maybe the Small Playfield + large chat log is still small enough to manage to save.

I really wish a Dev would provide some technical insight on the true cause of this problem.


#10

this is the first time this has happened to me, going to give it a try.

only thing I had done differently then any other character created, . . right after creation, didn’t even get to kill my first Alligator, cuz something came up and I had to log off, so I never had a moment to set my binds at the start like I normally do


#11

well it worked, but not the first attempt.
first time I was Night time and in the tavern, but I also pressed exit now, so can’t confirm if it was by pressing Exit now, or just doing it in the tavern was a bad spot

So I went day time, and entered a private instance, logged out, all the way out waiting, rather then pressing 'exit now", relaunched game selected character, press play . . all binds stayed

So guess doing it in the tavern, didn’t work out for me, had to go into a more private location :smiling_imp:


#12

Yeah, you have to let the Countdown timer tick all the way down. Hitting Exit Now causes settings to not get saved to the Server.

Also, the tavern is not actually its own instance. It is part of the same zone as the rest of the City of Tortage area. They just teleport you into a little floating building off on one edge of the map.