Corrupted Powder no longer dropping in The Summoning Place chests

Game mode: [Enter game mode here: Online private |
Type of issue: [Enter one of the following: Bug |
Server type: [Enter one of the following: PvE-Conflict |
Region: Dallas, TX, USA

After today’s hotfix, Corrupted Powder is no longer dropping in The Summoning Place chests.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Go inside The Summoning Place and none of the chests drop the powder as before.

People are probably beating you to the Summoning Place and taking the powder.

I’ve now been there 11 times and only found powder once.

1 Like

No, I’m the only one there. I know where everyone else is, I asked before going in. Also, nothing else (such as Bones) is touched in the chests. Maybe the drop rate decreased but that isn’t mentioned in the hotfix notes.


The powder is there. I have been there several times and there is always powder in a couple of chest. If you use a mod that increase stack size the powder will not be there. I learned that from testing different mods.


We are vanilla. Its too late for me to make another run at it but i am used to at least every other chest having powder in it as before. Ill hit it again tomorrow and then close the thread if i have a different experience.

1 Like

Cant confirm. Did a few runs post the hotfix patch, ended with 50 powder or so.


I ran through and got 21 powder this time. I cant close the thread. But its definitely way less than what it used to be.

Will test that asap.

There was also problem with the recipes in last patch. Simply couldn’t see any recipes in the firebowl after learning them.
This happened on singleplayer, privat servers. Without any mods of course.

While same worked fine on testlive.
So yes, to test and see diffrerent results of course.

But to make it clear. Do you use any mods on your server ?

I can’t confirm this issue. I did learn them yesterday and can see them just fine on both servers I play on (official and private) but let’s keep it in a designated thread. i believe you did open one:

Ok, like said, did some tests also for the corrupted powder.

The powder wasn’t never a problem for me, and like i was expecting, all or most all chests in the summoning place had some in.

But like described in previous answer i had an other problem with the feats to learn and not showing up.
A game-files verifiction solved this issue for me.
After all it was a big patch, and this may still happen, so maybe, maybe this could also help, worth at least the trial. :wink:

Anybody know what they did with the Skulltaker feat totem that used to be outside the entrance to Summoning? Ive looked everywhere for it but not gonna open a bug report just yet… I actually use that feat…

It’s been moved a little inside. I recall it up some steps on the right hand side against a wall.

I was tracking this down after the patch. A bunch of videos and maps and sites still refer to the old location.

Edit: My earlier post said there was a book (the book is something else) but the location of the skulltaker totem is accurate. See more details below :+1:

Up the stairs on the right side where cannibal brute spawns.

Found it :slight_smile:

1 Like

chests can still bug out and not spawn anything in at all… in which case you need to destroy the chests…
I make it a habit to destroy them after looting them just so it re-spawns properly.

Could it be that people do not close them? Because I had no issues at all and they did respawn on cooldown. If you destroy them, it will take much longer for them to respawn. If you loot them but you dont close them, they will take much longer to respawn. One thing I havent tested yet is what happens if you loot 1 item but leave the rest, will this trigger a new spawn or would the game still consider them full. If this is the case, it may explain why no power was found by some players.


In my experience taking only one item will still trigger a new inventory spawn next time you open it.

1 Like

really? in all my experiences it does not do a new respawn, unless its a recent change…

1 Like

I’m pretty sure the entire cell reset if you go away long enough. There are different npc there every time even if I don’t kill them and I usually only takes bones and powder. I don’t know if it is different only single player mode.

It should be different single player vs multi if threads I’ve read about thrall farming are correct. The game is forced to “remember” zones in multiplayer (even when players leave zone) so the same instance exists for all players that enter after. Not true for single