Crash on startup; Linux distro POP!_os 22.04 LTS

Playing on steam.
Crash on startup as soon as opening movie starts.
I use mods however I have disabled all of them and I still get the crash.

Crash logs report Conan is unable to connect with steam.

I used this guide to make Conan work on Linux;
(funcom forums site) guide-running-conan-exiles-on-linux-with-steam-proton-and-battleye-runtime/182931

I played Conan with mods on the day before age of war came out. Conan worked perfectly, tried to play on the day Conan was updated and it has crashed on startup ever since.
Only exception is when Conan booted up and it loaded in ok, until I got to the main menu and it wouldn’t let me do anything because Steam authentication failed. I don’t know what proton build I launched Conan with that time but I can’t seem to reproduce it at the moment.

I am very much connected to the internet, and connected to Steam. I would greatly appreciate any help or suggestions.

Nividia 1660 Super
Intel Core™ i7-10700K CPU @ 3.80GHz
POP!_os 22.04 LTS 64 bit

1 Like

Greetings @Foxtrot-007 ,

Thank you for your report.

Are you still having issues to open Conan Exiles?

If so, please follow the steps to verify your game files:

  1. Open Steam
  2. In Library, click with the right button on the game and select “Properties”
  3. Select the Installed files
  4. Select Verify integrity of game files….

Thanks in advance! :slight_smile:

Verification finished, but now Steam says Conan is running however it’s not starting the GUI/application. I tried multiple versions of Proton, and nothing. I haven’t tried many launch configs though.

Greetings @Foxtrot-007 ,

We did see some issues to accessing Conan on steam during the beginning of this week, however that seems to be solved and we can see players accessing the game.

If you don’t mind could you try to reinstall the game and use the “Change Account” option on steam?
You can log into your account right after, it’s just to force the account sync.

Hope this can help you!

I’ve had similar troubles since the Age of War patch. (And the recent hotfix patch on 2023.06.29).

Running Zorin OS 16, (Ubuntu 20.04 LTS) with the following specs:
i7-12700k, 64gb ram, 3080Ti

I’ve verified files, removed installed mods, done a full redownload of the game/clean install. I have tried different Nvidia Driver versions (I was previously on 525, and updated to 530 with no change.)

Similar to Foxtrot-007, I was able to play with mods. I am now unable to get to the main menu of the game. The funcom launcher will load and I can launch. Depending on Proton version I can play the cinematics. (Seem to have the best luck with Proton 7.0-6. This is what I used prior to the latest patch.) If I disable the cinematics I go straight to a fatal error upon launch.

The additional launch options I am using is only “-battleye” (I play on unofficial servers that do not require BattleEye.) And I also have the BattleEye disabled via the launcher.

These problems have persisted after the latest Funcom Live access issues I think you’re referring to previously in the week.


I also tried the suggestion of Changing Account on Steam. Still same fatal error upon game launch.

Yep, sounds almost just like my issue. Maybe after enough Linux users asking Funcom or a coder will find a way to make Conan Exiles compatible.

1 Like

Running on Linux Mint, also having same problem. Was only able to get the game to work on a Windows 10 VM.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.