Custome Thrall Names

Hello, I have the following problem. My Thralls lose their names given by me after a restart of the game. I have to rename all of my Thralls every time that happens because they revert to their default names. I play in single player.
I use different mods. Perhaps it is known that a mod causes problems in this regard?

1 Like

I have the same problem, and I haven’t found the culprit. For now, I am not certain whether this is mod-related. However, I am routing through my mod pile now, and I will let you know if I find the problem.

1 Like

Yeah there’s your problem for sure, but specifically which mod is doing it is a good question.

1 Like

Your path is to disable all mods, then enable one at a time, until you discover the culprit.

This will be tedious.

1 Like

Did you find out what is causing this problem?
I’ve disabled some mods that I thought might affect Thrall names, but it didn’t help. :pensive:

Not yet, @Dark_Overlord. I unloaded all mods and started trying mods one at a time, but then I got sidetracked. I will try again soon. Sorry for the delay.

It’s the amount of time needed for the game to reload each time I change mods that is really killing me.

1 Like

No problem. Thank you very much for your efforts :slight_smile:

You can probably find the culprit faster by enabling half your mods, if the problem is there - it’s one of those, if not - it’s one of the other half. Repeat until you’re down to one.

Disclaimer: Not a guarantee since multiple mods can cause the same problem sometimes, but if you have a long enough list it can still be worth it.


In coding terms, this is known as the “Bubble Sort.” It’s a great strategy.


Definitely in the presence of IT pros (or at least pro problem-solvers). :wink: Great idea! Thanks!

1 Like

The following mods DO NOT cause the thrall name change bug:
Single player boss HP (may 2018)
WYSIWYG Wheel of Pain
Less Building Placement Restrictions

Now to add (one by one) the other 10+ mods I use, load the game, change the name, load the game (again), check the name, log the mod…and I will eventually be back with one or more “winners” of this contest. :hot_face:

EDIT: Meanwhile, here is some casual reading for everyone (especially mod authors) while you are waiting. The Theory of Modding - a humble request. Did I mention, clean-as-you-go? Yep…twice! Updating to the newest dev kit helps too!

Finished with some good news and some really confusing bad news. The following mods were unloaded (not unsubscribed) and reloaded one at time. When I got to the last mod, the name change feature worked. So, I thought this must be a mod-conflict, not a particular mod, because my ending mod order was different than the original. To confirm this, I replaced my mod list file (located in “:\Steam\steamapps\common\Conan Exiles\ConanSandbox\Mods”) with the original mod order. I also replaced game.db with my original save-game file (located in “:\Steam\steamapps\common\Conan Exiles\ConanSandbox\Saved”). To my surprise, I could still rename thralls, even though the mod order and game.db were the same as what I started with.

How is this possible? How did unloading/reloading my mods change anything? There were no mod updates since the start of this process.

Yes it’s very confusing. I installed Conan Exiles on a different pc, with all the same mods as on my own computer. Same problem. Thralls with names given by me got their old names back (cimmerian fighter, etc.). So I deleted all mods and startet a new game without mods. And now all Thralls reset their names after restart without any mods activated. Maybe its a bug not a modproblem? Maybe both >.>

No I don’t think there’s any chance of this being a general bug. You’d see way more threads/reports about it, then.

At most, it can be a bug (in a mod or introduced by a mod) that has been fixed, but persists in any game.db that had the faulty mod at some point - that’s been known to happen from time to time.

On Testlive server this issue does not occur. So, it is not a game bug. It is more likely a script or something left over from a mod (maybe even a mod that I no longer use).

I am going to check my savegame database (CheckGameDB). NOTE: Backup your saved game.db files before doing this, because files that fail will be auto-deleted!

Also, @Dark_Overlord, could you please post your mod load order so that I can find mods we both us in common?

EDIT: All saved game files (“game.db”, etc.) were verified to be “OK”.

One mode that caused such problem was StraysThralls by Stray Genius. It was updated yesterday but I hadn’t tested it yet.


That must be the culprit for me at least, @Ko6ka! I have that mod in my list, and I can’t think of anything else that might have changed. Thank you! :star_struck:

@Dark_Overlord do you use StraysThralls?


I updated straythralls. Now it works! Thanks to both of you :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.