D3D - REMOVED Crash bug


#1

Game mode: [Online | Singleplayer] - All
Problem: [Crash | Bug | Performance | Misc] - All
Region: [Ontario Canada]


Line 181 - Unreal Engine is exiting due to D3D device being lost.

This bug is causing unpredictable crashes while attempting to login, as well as causing random crashes within the game itself.

It is an issue that has persisted through multiple patches and hotfixes. Some seemed to make it better, others made it worse.
The most recent 2 hotfixes seem to have made it worse.
I am currently unable to login at all for spans of hours, then, if it lets me in, it will crash within the first 10-15 minutes.
Killing/fighting mobs caused crashes.
Crossing zone boundaries caused crashes
turning/moving the character at all while in the Relic Hunter’s city caused numerous crashes.

Computer exceeds minimum requirements by a considerable margin. Turning graphics down to bare minimum had no effect.
All drivers are up to date.
Windows is up to date.
I have run the Steam Integrity verification for the game several times as well.

This bug is making the game COMPLETELY UNPLAYABLE.


Steps on how to reproduce issue:

  1. Start up game.
  2. Watch or toggle out of the Intro cinematic
  3. Choose single player, join another game, or server (doesn’t matter which - all affected)
  4. Wait for loadscreen - Game crashes prior to loading in the character or map. - line 181 error

Steps on how to reproduce issue:

  1. If managing to get into game
  2. Move - turn in place, move the character, toggle inventory, etc. - Must give the game a few moments to finish loading or it crashes. (sometimes this does not work)
  3. Game Crashes - Same line 181 error.

Steps on how to reproduce issue:

  1. If managing to get into game
  2. Attack and/or kill a creature (human or otherwise) - won’t always be on the first swing, usually its as the mob dies, but not always.
  3. Game Crashes - Same line 181 error.

Steps on how to reproduce issue:

  1. If managing to get into game
  2. Moving across zone boundaries - causes small lag spikes. If I don’t stop (and sometimes even if I do) these cause another crash.
  3. Game Crashes - Same line 181 error.

#2

Hello,

Is your card overclocked? Which card is in use? Which CPU? Such error could also occur if a video card is overheating.

Update your drivers.
AMD: https://support.amd.com/en-us
Nvidia: https://www.geforce.com/drivers


#3

Its not an overheating issue, as I have tried starting the game up shortly after bootup, and have ensured the computer is dust free. Cleaned it recently in case this was the issue, and it had no effect whatsoever.

Drivers are all up to date, as mentioned in the OP. Windows updates are also up to date, etc.
Its an NVIDIA Geforce GTX 750 Ti

No its not overclocked.

the only method I have found to deal with this issue myself is to tinker in my computer’s registry, which I won’t do.
Its up to developers to fix (Funcom, Microsoft, and NVidia developers, all three) from what I understand.


#4

Maybe it’s geforce experience… That gave me so much headache and i uninstalled it because gfe wants to “optimize” games by itself. Maybe this will do the trick.


#5

Just posting an update to this.
Still unable to log in. Nothing has helped.
From what I understand, the D3D crash issue is known to NVIDIA, and they’re “working on it”

HOWEVER.

I would like to point out that there HAVE been changes to this crashing issue with various patch releases. Some improved it, others made it worse.
the last 2 made it worse.
This has been my experience with this crashing issue:
End of June: Started playing - Crashing issue was present, but small. I was unable to log onto co-op or server, but able to access my own single player just fine.
Eventually the singler player server began to crash, and it was impossible to get into Co-op or onto a server. Eventually figured out that once I was able to access my map, I was able to also join the Co-op for my husband’s map. Once in, game was mostly stable. The occasional freeze, and/or crash, but few and far between, and usually only after I’d been playing for a while.
Patch released, and login crashes improved. I was able to access husband’s map more easily, but crashes within game also increased. These crashes were more bearable since I was able to relog in relatively quickly.
Another patch released, and the game slid back to what it had prior, with long times between successful logins, but THEN there would also be more crashing within the game.
Another patch released, and this became even worse. Game is currently unplayable. I am unable to log in at all.


#6

Alright i have an idea.

Download the newest Nvidia driver
Link: https://www.geforce.com/drivers (select your card, OS, language and click “start search”.)

Uninstall the GPU driver with DDU (display driver uninstaller.)
Link: http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

Safe mode is recommended if you want to uninstall 100% safely but it works also in regular mode. I did it a few times without any issue. After you uninstalled the nvidia driver with ddu reboot your pc.

When your PC is ready again, install the new GPU driver WITHOUT GeForce Experience.

This COULD help, maybe the driver is corrupted. Just give it a try :slight_smile:


#7

Tried reinstalling the drivers once already.

Conan is the only one I’m having this particular issue with, however I have found that people are having this issue with other games as well.

Its an issue specifically with DirectX and Unreal Engine. My husband and I have looked into this quite a bit, and he’s very very knowledgable in computers. From what we’ve found, there’s nothing for us to be able to do, its on the developers to fix :confused:


#8

I had a similar issue with my GTX 770, clean re-install of driver did the trick.
You could also try an older driver version, maybe the release driver for conan exiles.


#9

As some have said, this is a known UE4 bug on their list of bugs but not high priority for some reason. There’s a protocol of settings that can be used when building the game in UE4 to reduce this issue, and Funcom said they were doing this at one point. But maybe they’ve slipped in all this patch madness.

Some people are able to find a workaround. But the workaround seems to vary from case to case. In some cases, it’s replacing drivers. In other cases, it’s down clocking the GPU or something. In my case when this exact same error started a couple of months ago, I had my system RAM overclocked to its max rating, and I lowered that down until it was stable in the 1.2V range. Since then, I’ve not had a problem with that error. Why that worked, I have no idea since I played through Witcher 3 twice on ultra settings with my previous RAM timings and never had a problem.


#10

Uninstalled and reinstalled drivers, rolled back to earlier release - no effect
uninstalled Geforce experience - no effect
re-updated drivers - no effect.
uninstalled some other games - no effect.
nothing is helping.

Windows update this morning - again, no effect.

If this is a known bug on their to do list, why does it not have higher priority? Its a game breaking bug…
I can play just fine on my husband’s computer, his has no issues. but mine crashes every single time I’ve tried to log in since the last patch.


#11

From what I understand, UE4 bug priority is essentially decided democratically, by votes, among UE4 developers. So that is where voting has ranked it.

What level of graphics settings are you using in CE?
No offense, but a GTX 750 Ti isn’t a particularly robust graphics card by today’s standards. On ultra settings, CE uses almost 6 gigs of VRAM on my system. You’re going to probably have to set the graphics settings down to a fairly low level to run smoothly. A lot of people including myself are getting some large graphical stutters in the latest patch. It’s not crashing the game for me right now but it’s crashing for a lot of people. Your graphics card may very well not be able to handle an unexpected and large load placed on it by CE that was the result of some poor optimization or glitch.


#12

I did try turning the graphics settings all down to low, and that made no difference :confused:

I started out, originally, with settings all set to low. Once in, I tinkered to see what ran smoothly and gave the best appearance to my liking. Most were set to medium, a few set to high and one or two at low. Nothing was at Ultra for longer than a moment or two just to give me a sneaky peak at what it might look like on higher settings.
If it sounded like my computer was working too hard, or framerate dropped, etc, I toned graphics back here and there.
As mentioned, though, these crashes are happening regardless of the graphics settings. I’ve had them turned all down to low (and even low end laptop setting) to see if it would affect the crashing, and it did not. Crashes happened just as often at lower settings.


#13

That’s unfortunate. Only thing I could recommend is to download some UE4 engine demos or benchmark software. See if they work normally or produce errors. Try to track down any UE4 stability issues from that angle using other tech support databases. That would at least indicate whether or not the UE4 engine was having issues with your specific hardware or operating system.

Other than that, the only thing you can do is to wait for Funcom to release a more stable version.


#14

another update - July 13
Last night, I uninstalled and reinstalled the game, started a new game, at lowest settings possible. No mods.
It finally let me in. However, the next time I logged in (this morning), it crashed again - with the same error message. Only change to settings I made was to the resolution.
It let me in again after a second login attempt, and, so far, has been stable within the game itself. This is what the game had been like when I first got it, a couple of weeks ago. Crashes got progressively worse after that, though.
My best guess is that the crashing corrupted something within the game, that Verifying the integrity of the game through Steam was unable to fix, and that this will continue to happen until the underlying cause of the initial crashes is fixed.

Edit - Approaching a fight between a couple of crocs and an exile, the death of the exile caused the game to crash again. Hopefully it lets me back in.

Edit #2 - Crashed again… and again, it involved exiles. Approaching an exile camp, fight was just beginning, and it froze, then crashed.

Short bit later, a third crash in game, and… again… involving an exile. This time it was the friendly at Shaman’s Rise. So far the game has let me back in quickly after these crashes.

Edit #3 - managed to play for a bit, and game was stable. It seems to be human npcs causing the crashes from within game. Its possible, that thralls near my login are/were causing the crash at load up. Crashes in game seem to coincide with npcs the first time they’re encountered. Respawns seem to be alright.

And with this last crash, it has returned to not allowing me to log in again. Crashed near an exile camp. Edit: 3 login attempts got me back in.

Edit 4 - Crashed again, though this time there were no human npcs involved. It was an area north of the giant croc pond, near a kudu and some antelope. I THINK this is a zone boundary, maybe?


#15

Yeah, I get a lot of stutters when I first load into a game around my base with a lot of thralls and crafting stations nearby. The stutters can be a freeze that last a full second or two, as if it was going to crash, but usually it comes back. At which point, my character will teleport some distance as if the animation and movement had continued in the background during the freeze. The frequency of stutters calms down after a few minutes of play, but they’ll occur occasionally later on when running through some random area. That’s in single player. So, there’s no server or connection lag to blame it on.

So, even though they’ve fixed some things in the last couple of patches, graphics performance has become somewhat unstable. Hopefully, they’ll address this issue in the next patch.


#16

Yeah I’ve gotten some of those stutters too a bit.

they seem to happen mostly in the desert regions, but I haven’t explored too much toward the east or north yet, only ventured out those ways a couple of times, so that may just be a lack of exposure.

Managed to play on my husband’s map for a while yesterday, and most of the crashes, again, coincided with human npcs of some sort, though once I was in the north lands, they stopped happening.
Just had a few little tugs backwards in a couple of areas, near the border between the desert and the north lands (approaching one of the tunnels, then again on the other side of it though I don’t remember exactly where)
Going to try to create a small base away from npcs as a login/logout point, at least until this issue is resolved.

Also to note, BECAUSE of the crashing issues I’ve had, I’ve only been playing on Single Player and co-op. I had managed to log into a private server once or twice, just prior to release of the recent big patch, but the crash issue prevented further attempts.


#17

Crashes seem to be gradually increasing.

Also noticed something strange when I managed to get back in after the last crash…
my weapon was duplicated. I have a copy of the same weapon in my inventory, with the same amount of durability. Pretty sure I only made 1 Iron poniard, and never picked up a second off of a kill, but now I have 2.
I crashed beginning a fight with an exile, using said weapon.