Daggers became absolutely useless

Game mode: [Singleplayer]
Problem: [Bug ]
Region: [Here]

Daggers became absolutely useless. They stopped adding the effect of bleeding to the enemy. At the same time, NPC daggers put this effect on my character.

I noticed this over the weekend, since Thursdays patch. Seems the bleed icon shows, but there is no damage from bleed anymore.

I think bleed has been rendered useless, no matter how it’s delivered.

Same with palisades. It shows I get the bleed effect on me, but I receive no damage. I use to receive damage from them before Thursdays patch.

Still works for me, alas it seems to be rather wonky

Not the best quality and I messed the movement/camera a bit messed up, but I had to make it in a hurry.

Bleed damage is just reduced not eliminated, was in patch notes I believe. Still has killed NPCs for me.

Still works for me too though nowhere near as powerful as it was before. TBH it was a bit overpowered compared to other damage types. All you had to do was hit anything with your dagger a few times then keep running in circles while it died. It’s a bit more difficult now, as if should be.

Everyone writes that the bleeding works. And it does not work for me. I have three modes not associated with weapons, but I tried to play without mods. Nothing changed. Two or three patches ago everything was fine, now …:sob::sob::sob::sob:

They could use a slight buff in bleeding. But the lack of heavy cooldown is still super OP.

You are using heavy attacks aren’t you? Only heavy attacks add the bleed effect. I have noticed that I’m missing a lot more with the daggers than I used to. I carry a spear/pike around with me now as well since I can no longer rely on the daggers so much.

Have you tried making a new pair of daggers? Maybe old ones are bugged? Who knows…

Indeed, only way to go. Stone daggers are super OP and cheap. I can clear New Asagarth with a few sets, in cloth.

1 Like

If you have the Khitan pack, the low-end daggers are super cheap and awesome from just about as soon as you can access a smith. I have used dagger bleed predominantly, with greatsword finisher, for the last many days.

1 Like

I do, all the items are great. Love that DLC.

1 Like

Daggers are still working for me also. I don’t doubt that some people experience different issues. Fortunately for me, I haven’t come across anything weird yet with the new patch.

Yes, I finally figured it out. Bleeding happens only from heavy attacks, and I used mostly light attaks. Thank you all for your advice.:grinning::grinning::grinning: