Dark Ruins bug?


It seems like I may have a strange bug happening in Dark Ruins.
I cannot speak to ‘Administrator Ivar’

I get the mission to go and speak to him, but when I right click on him… It say’s “mission accomplished, you got a new mission.” However there is no new mission and when I click on him the dialogue box does not open…

I can go back to the previous NPC and get the mission again which says something along the lines of 'Who do I speak to?" Or something like that… However still get the same result when trying to speak to Ivar again.

I have tried to relog, reset the instance etc… But no luck in being able to speak with him to continue the quest line.

I have also tried to speak with every NPC with no luck… I should also have a quest item as the quest is to pick up the flowers / bark however I do not have the item…

Any ideas?

Have you tried deleting the mission instead of completing it? Does that change anything? :slight_smile:

Sadly that was my first thing to do! But no luck unfortunately! And I’m not able to delete the “Gain the spirit guide’s Trust” mission either :frowning: