Deadlock: (also known as hang or hard freeze) Possible association with location polling

Game mode: solo
Type of issue:Crash
Server type: n/a
Region:U.S.
Mods?: No
Edition: Steam


Bug Description:

What is going on in the background in this game that causes a "hard freeze, hang (deadlock condition) that requires me to shut the power off and reboot this sytem?

I don’t know what to tell you people.
I can’t get any reports on this because I am forced to power down and reboot this system.
Windows 10 Pro (Full Retail Version).
AMD 9590 CPU /water cooled 4Ghz +
32 GB Ripjaws RAM
Samsung EVO860 1TB SSD

This has been reported several times.
Yet, I still keep getting a random deadlock without any warning.

But as noted later in this thread, one thing came to mind.
“polling”. (related to in world position).

It doesn’t seem to be a widely spread game issue which makes me believe that it is something specific to your hardware/software. Faulty PSU?

Have same issue.Before rebooting system but ctrl+alt+del and turn off process works too.Same type of processor-amd FX.Just 8350.

that’s likely the issue
what’s your CPU temperatures prior to crash?

I think its not connected to temperature-have good cooler and processor is working ok.In hot days(30 in room)game not crashing.Possible is some specific architecture or drivers problem

It’s a water cooled CPU that keeps it well below critical temps.
People who have experienced this issue have quit this game and won’t be coming back. That’s why this issue seems so un-widespread and you pose the assumption it’s my hardware.
I’ve been exceedingly patient about this. So patient that I’ve put in over 7000 hours. I have lost count of the number of times this has happened.
I am beyond infuriated.
But, you know what?
The one thing that keeps me coming is the beauty of the game.
I just wish they would figure out what’s causing it and finally fix it.
It’s an issue between the game engine and windows. That’s obvious.

I had the same until I updated the video drivers to the freshest ones. Radeon video card, install fresh Radeon Software.
Plus manual control of the fan speed, there, by default, a weak frequency is set on strong heating.

1 Like

I’m sorry, but your problem is way too different from mine.

I get the periodic hard freeze where I am required to reboot the computer. Overall, it rarely happens. (Twice since 2.5 and I log in daily.)

Only able to see the windows menu screen so restarting the computer is not an issue. Only mentioning it since it does happen but not too concerned about it.

Whether it’s widespread or not is pure speculation without any numbers. The only way for Funcom to get those numbers is to report the bugs. People who quit playing the game without reporting the bug are well within their rights to do so, but that doesn’t make this whole issue anything more than guesswork.

Suspecting your hardware and/or your system configuration is perfectly reasonable diagnostic procedure in absence of any hard data.

Yeah, I get that you’re frustrated. It sucks not to be able to play the game. But I also don’t see how anyone can even try to help you without data. So either you want help and should work with people asking you questions and giving you advice, or you don’t want help and you just came to vent and everyone should leave you to it.

Which is it?

3 Likes

Believe me CodeMage, I’ve been down that road and it has cost me plenty of money because of ill advised second hand guesswork with unnecessary, unneeded “upgrades” to hardware. I’ve even taken this PC to professionals to have them look into this. They could not find any issue with my hardware or software.
This issue started after the release of the North and Jungle Biomes. It doesn’t matter which map you’re on. It happens on Isle of Siptah also. It happens randomly and it will lock up the Windows Processes with no escape except to do a hard reboot. It can’t generate any related data because it affects the Widows Process.
People did complain about it, but were either ignored or ill treated the same way I’ve been treated by elitist snobs who apparently have been fortunate enough to have not been suffering the same issue.
This is NOT a SPAM post. It is an ongoing issue that needs to be addressed.
This isn’t the Testive Version, this is the release version and no mods (whatsoever) have ever been used.
People have quit and uninstalled this game after the first time this event happened. Anyone in their right mind would uninstall a “defective” product after the first incident of this magnitude. Why should they bother reporting it. Even if FC got their money it still means loss of future revenue and more loss of money because of a “thumbs down” for any referrals for new customers. Someone “up there” should have realized this.

But that’s just it. No hard data can be gathered simply because it also locks up the Windows Process. A lot of people don’t have the same patience I’ve had with putting up with this. I may be one of the few remaining who still experience it because I’ve had more than enough patience and faith in those who made this game.
No hardware update, no software update and no amount of money spent on hardware “upgrades” has had any affect on this random issue. I’ve already spent several hundred dollars (U.S. currency) to well over $1000 above the $1200 cost of building this PC myself in trying suggested and intuitive “fixes”. How can FC fix it if the very same issue does not affect them? They can’t unless they also experience it.
If they wanted my PC to see this for themselves, I’d gladly ship it to them. But you know what? I don’t think they’ll go there with me because they’re preoccupied with other apparently more pressing concerns and I see those matters all over this forum and in the Steam Forums.
Do I want to vent? Simple answer is no. But I don’t care for people hammering me with attitudes. If I didn’t have this issue, I would be a happy little clam nestled away in my little corner of the world. But I’ve allowed myself to get into this up to my neck and I’m not about to simply drop it and let it fade away.

Now if you’ll excuse me,
I’ve personally got other more pressing real world matters to attend to.
I’m sure you do too as well.

1 Like

Bingo! Which is why these problems persist. However, the info you provided in your latest post should still be useful. Now everyone who looks at it will also know that:

  • you’ve had the PC looked over by professionals and they couldn’t find anything wrong with the hardware or software
  • it started after the release of the Frozen North and the jungle

Other details devs might care about are:

  • your GPU
  • your drivers version
  • whether it happens if you play the game without BattlEye
1 Like

Thank you. I appreciate that.

1 Like

one thing to make certain - I’ve had issues with CE and the task manager after changing over to win10 when that issue with the inventory causing the game to crash was going around recently. Something was blocking the task manager from being shown over the game window for what ever reason when opening it with ctrl-alt-del.

You could try ctrl - shift - esc, and in the options menu make sure that ‘Always on Top’ is checked.

EDIT: just to rule out the possibility that it may not be a hard lock rather than just windows being windows. When it first started happening to me I was having to do restarts as well and thought the game was making the system lock up.

3 Likes

Good info.

I’ve tried them all. Very rarely was the Windows button + X able to call up the power user window and then be able to initiate the task manager to end the “not responding” process. But 98% of the time, it was a hard lock condition with no recourse but to power down and reboot.
Granted, this system isn’t the “latest and greatest” top line , poo poo “recommended” such as a Ryzen Vega high dollar rig. But it was and still is more than adequate and capable setting comfortably high on the graphics scale before and since the expansions came out. It’s just the hard lock issue began after the first expansions.

Even my old server rig running dual opterons had no issues running this before it perished before the updates and expansions.
This system is a gigabyte 990 FXA UD3-R5 mobo with 32GB Ripjaws RAM, and a Samsung 860 EVO SSD, it’s a water cooled AMD FX 9590 running on a new “Platinum” rated power supply. With an AMD FX5500 XT 8GB dedicated card. Windows 10 PRO (Full Retail) latest update. Drivers are up to date as necessary when applicable. More specifically, BIOS settings are using defaults and no changes were made since that was updated. No overclocking because it is unnecessary and not even needed.
It has affected only this client. It did not affect the rented server I was using. Still it occurs playing this game solo either on the Exiled Lands or Isle of Siptah. (since I’ve shut the server down).

There was a brief time when it began affecting this system while playing a different game. But following Windows updates resolved the issue involving that game. However, although the Windows Updates did not resolve the issue while playing this game, the issue seemed to occur less frequently until additional updates to this game renewed the increased random frequency at which it occurs. Believe me, it’s been infuriating enough to uninstall this game more then twice as it has pushed my patience. Still, here I am after having installed it again a third time (or 4th time) and damn it all, the issue persists.

Tell me that isn’t a programming conflict issue.

I just hope someone with deep programming experience can get to the bottom of this and maybe point the people who made this game in the right direction.

2 Likes

Yeah, sucks cause you seem to really like the game when you do get to play. Have you tried doing a stress test? Start with all video in game settings on low and slowly ramp up until you get the freeze. May be a work around until something definitive is figured out.

I’ve put this rig through various stress tests as well as various scan and repair functions. All of them run via the Windows Admin Command Line function per advice of the Windows 10 community.
If it had found the issue through that process, I’d be happy because it means I could have fixed it.
But it’s no dice. What’s going on is deeper than what I can understand because these windows functions don’t scan (and repair) installed applications that are not of Windows origin such as this game.

Gotcha. I feel lucky I only have issues on heavily modded privates or 9ver built servers. Things I can avoid. Again, hope some tech head figures it out beyond get a better PC advice.

2 Likes