Dedicated server can no longer be connected to after update

So I got a dedicated server running that me and my friend played on for a few weeks, until the recent update did “something.” For starters, I’m running it on the same computer I play on, which I read in the sticky isn’t supposed to work…? But it was working before. So I’ll list the solutions I’ve attempted, and what they did when I tried them.

I’ve reinstalled both game and server app, no changes.

I tried changing TCP and UDP from 7777/7778 to 7775/7776. Changes nothing for me, nor my friend attempting to connect. App reports them both “red” on both options, but due to my ISP, I’ve always had ports considered blocked by programs, but weren’t actually blocked.
Tried changing steam query to 27015 from 27016. As expected, I can’t run the game AND the app on 27015, so while my friend was able to connect, I was not able to, even with direct connect. The kicker is that while I can direct connect while it’s 27016, I CANNOT connect through the server browser, which I was able to do before (albeit with a very long wait to join.)
I have not attempted any other ports than I’ve mentioned, as I don’t have anything else running that should be using the same ports.
I dug through windows firewall to ensure that both game and server had no restrictions, they don’t.
Went through my router and double checked that all ports were opened, TCP and UDP, and query ports. Also restarted router. No changes.

I have attempted flushing my DNS and restarted computer after, as I found in another post.
Also attempted changing steam refresh rate thing, no changes.
Tried waiting for the problem to magically solve itself. It didn’t.

Honestly I feel like my friend messed something up on his side, but he promises that “I didn’t touch anything, it’s your mods that broke it.” Because mods somehow affect netcode now. I’m also leaning towards the idea that it’s the recent patch that broke it since I can’t connect through server browser anymore, which is what I was doing before.

Well, that’s pretty much everything. I’ve probably forgot some stuff, but if anyone has any ideas, please let me know. I don’t expect any response from the big wigs over the weekend, but I’ll see if there’s anything else I can mess with that magically solves the problem in the meantime.

Well I got it working, and I want to say that it was the multihome option I changed, but that was something I remember trying earlier with no results. It’s possible I had a value wrong or something, or maybe my computer or router just got it’s head out of it’s ■■■.