[DevKit / Live] Merging ComboRules makes Wildlife AI unresponsive

Game mode: Online private / Singleplayer
Type of issue: Bug
Server type: Any
Region: Any

When merging ComboRules in the DevKit it will turn any non-human NPCs unresponsive and cause them to not attack players or other enemies. This can be recreated 100% of the time.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Create a new table in the DevKit under Misc
  2. Select the ComboRules struct
  3. Merge with basegame ComboRules through ModController
  4. All non-human NPCs are now unresponsive

This is one of the most severe issues coming with this Update. I will probably take my server offline waiting for the next Funcom Patch, which hopefully will come today. :pray:


Hey @Hosav

Thanks for the report. We’ve notified the team about this devkit issue and we’ll hopefully have it addressed soon.

1 Like

I have the same issue here, in addition, in the devkit all the mob ‘Weapon Combo Types’ are empty (see the picture)

The flow to reproduce by my side is :

  1. Create a datatable with StringEnumTableRow
  2. Create a StringEnumDataTableDataprovider
  3. Feed the dataprovider with the datatable
  4. Create a new ComboRules struct datatable
  5. Merge with basegame DT_ComboRules through ModController
  6. All wildlife IA are now brainless
1 Like

We’ve assigned a coder already to get this issue ironed out ASAP. Thanks for the feedback!


Yay! :heart:


I am having this issue on my server and we dont run the DevKit? Am I missing something here?


It’s a mod issue, so if you have a mod that alters the combo rules table, the result is as described in the thread.

All the dev kit stuff is for us mod authors and for Funcom.

1 Like

Ah ok no problem, so I wont be able to narrow it down to any one mod I assume. It will be most that alter anything to do with combat?

Thanks Multigun :slight_smile:

When will the problem be solved. Huge numbers of players use Aoc and EEWA.

Per the mod discord, the fix is being worked on now (I know that’s not an exact ETA, there never is one though). There is a temporary work around for us modders in the mean time (which will require both mods to update again in order to apply).

The eewa discord announced that they have a work around they already put out

I have the issues too and I do not run AOC or EEWA

It can be any mod that edits ComboRules, and there are a lot.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.