DLC not unlocking

Single-Player and Private Online
Technical Issue
United States

I purchased the DLC’s in the steam store and they will not activate in-game. All show as purchased on the DLC splash screen when starting the game, but items are unavailable in-game both on servers and in single-player.

I have tried restarting steam, restarting my PC, reinstalling Conan Exiles, and reinstalling Steam.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

Did you unlock the pre-reqs in the feat menu?

Yes I have unlocked all the pre-req feats, and I have even used the admin console to unlock all feats, and the DLC feats are still unavailable

There is very little information to go off of, but it’s something on your end. Learn the pre-reqs, click the unlock button. It won’t show up as completed initially, just close the feat window and open it again and it will turn green. Then craft the appropriate weapons, armors, and placeables in the correct workstation.

Either that, or you are using a very out of date mod that is blocking it.

1 Like

Sometimes the DLC is not ticked in the steam window.

On the steam Conan Game page scroll down until you see the DLC window
click the Manage My DLC link

Make sure the DLC box in the Enabled column is ticked

I don’t know if this is the case, but it has happened to me with other Steam games.

I have double checked that all DLC’s show in my list on steam and all are checked as active, still no go

I have also tried with and without mods enabled, and completely removed all mod installs. The DLC feats show up in the feats list with the green arrow on the icon, but the unlock button is grayed out and does not let me unlock even with all pre-req feats learned

I have heard about a similar issue. The person figured out that somehow his game doesn’t launch using a steam argument or sth like this causing their DLC to appear locked. Let me try to dig it out :slight_smile:

Here you go: [Need Help] Can't craft DLC armour or buildings Since I am not very good with the technical stuff, someone else will need to translate to you how to check and fix it in case you have the same issue :slight_smile:

I appreciate you taking the time to dig that out, unfortunately I have ensured that there are no startup arguments ( -nosteamclient, etc) running when I launch and it is still not working :frowning:

Hey @NilsWorthy

A couple more checks added to the long list of possible workarounds shared above. Have you tried validating your game files on Steam? Could you also check if family sharing is enabled as well?

1 Like

Hi Ignasis,

I have validated game files on steam and all came back good, nothing needed re-acquired on the check. I have also double checked that family sharing is turned off. The DLC feats are still not unlocking.

*edited for clarity

You don’t buy dlc with feats, Its just how menus look and work.

So when you buy Tier 3 stuff from base game, there no need to buy dlc. (via feats)
Scroll to another menu(like charcter inventory) and back. (or exit back out of mneu and in) and it should be green as if you spent feat points.

I would suggest popping open Admin Panel, and giving yourself some of items.
If you own DLC, you’ll get them no issue and not need for feats.
If you get error code when trying use Admin Panel. Then something is up with Steam and the Account.

If your able to give yourself items via admin panel, then you seem to be missing feats or not at right level. (even if you cheat feats, the game can be weird if your not right level)

I have tried using the admin panel to level myself and gain all the feats regular feats, but this still does not give me the DLC feats as they are still locked as if I did not purchase the DLC. I also am unable to spawn any DLC items with the admin panel item spawning.

If you cant spawn them, then the game doesnt recognize them as purchased.

  1. Are your DLCs ticked in steam as files to be loaded?
  2. Any chance that your game and DLCs are purchased for different regions?
  3. Did you purchase the DLCs directly via steam or using some code? Were they in a bundle?

I know you confirmed some of these already but can you maybe post some screenshots to re-confirm that we are looking at the same thing?

1 Like

I had this happen once. The DLC didn’t install automatically.

I had to go into Steam, then Properties for Conan, Click the DLC Tab, and then tick it to install it from there because it didn’t do it automatically. I think it was the Turan pack that gave me this issue.

I would double check this one, As DLC is not shared with other regions for this game. (most games honestly)

When you spawn via admin panel, did you get error code?

Can you confirm that you actually purchased the DLC in question? I know I’ve had a couple of purchases on Steam that “didn’t go completely through” that I’ve had to do over (not with Conan Exiles, but with a few other games).

Assuming you have actually purchased the DLC, can you confirm that the purchased DLC has been downloaded? (Sometimes I’ve purchased a DLC and told steam to install it, when it didn’t).

Assuming you have actually purchased the DLC, and you have it installed, can you confirm that you can actually see the DLC feats associated with that DLC content in your Feats list (like armor or building pieces)?

(just trying to help figure out what’s going on)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.