DLC content not unlocking after purchase (PC - Prereq. met)

Game mode: [Enter game mode here: (Online private) on PC
Type of issue: [Misc]
Server type: [PvE]

It won’t unlock the Yamatai Feats after purchasing the DLC. I have all the prerequisites unlocked, the main menu DLC screen shows I have the DLC purchased, it just won’t let me access them ingame… Unlock button stays grey, prerequisites box is green.

I run a private Dedicated Server on my PC, I also play the game from that PC. That might be part of the reason, I’ve tried starting the Server while Steam is closed and then starting Steam and the game client after it has booted, tried resetting my Feats, but nothing seems to be helping so far.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. See above.

Additional research:

Started a singleplayer game, leveled a bit and tried to unlock it: Still not working, so it’s not just limited to the Server.

Is it enabled in your steam library?

Yes, it’s enabled in the Steam library overview for Conan Exiles. The ingame main menu DLC overview also confirms I have that specific DLC, the other 3 are not marked as owned.

Currently re-installing the game from Steam after un-installing and manually removing residual files… hoping that does something…

1 Like

Hey @Mashidaru

Did this issue still persist after reinstalling the game?

Sorry for the slow reply, was a busy week. But yes! After a full re-install it seems to work properly.

1 Like

Thank you for letting us know and really glad to hear everything worked itself out. Enjoy your stay in the Exiled lands :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.