Bought Conan Exiles Complete Edition for PC, Leveled to 60 several times and still have yet to see any DLC content. Please HELP

Conan Exiles Complete Edition from Steam. Using Conan Exiles Dedicated Server from Steam.
(Do I need the Conan Exiles Dedicated Server to play Single player??)

Single Player, have not been able to unlock any of the DLC contents bought from Complete Edition Pack. Have reached Level 60 a few times - unlocked all the building feats and the survival required. Please, if you know how to unlock them Please Help , open to advice. Have even went as far as getting the Pippi Mod to add more feat points to unlock all feats, but the DLC content stays Red. Still new to the game, have only played a week. By the way Thank you very much for taking the time to read this and hopefully some1 will have an answer. I may not get a chance anytime soon to respond due to having a hurricane heading this way.

[PvE Conan Exiles Dedicated Server from Steam]
[North America]
[Have no access to any DLC content, even after Lvl 60 and unlocking everything else.]

1 Like

You have to buy them through steam store

Hey @BuliwyfWolfgar

Welcome to our community.

You don’t need the dedicated server to play in single player mode. To do so, just select the Single Player/Coop mode from the main menu.
Regarding the DLC content, make sure it all shows up in your Steam library page for Conan Exiles marked as owned and correctly enabled (they show a :white_check_mark:).
If all above is correct, you should be able to learn any of the feats of this new DLC correctly from the Feats screen (i.e. Aquilonian or Khitan Mason) provided that you’re at the correct level and have unlocked the right requirements first.

Please stay safe and see you once the weather is kinder. :slight_smile:

1 Like

The Complete Edition includes all DLCs (except the Riddle of Steel).


Thank you Ignasis, I was wondering about that. Could not figure out why the DLC’s wouldn’t work, so I uninstalled the game and reinstalled before working on Saving my parents house from Dorian, Thanks for the kind words, will be safe, We hope… Bought the Game and Complete Edition all at the same time. Some peeps are saying they needed to uninstall and reinstall before it worked, now my save game won’t work… LOL, copy pasted the old saves in to the Saved folder under SaveGames, but it keeps getting the info from some type of Cloud System, but my Microsoft and Steam Cloud have long been disabled… by me. So, I guess I will start a new game…

[Solved] - Uninstall the game, then reinstall it to be able to finally use the DLC’s. (Of course after you reach level 60, I used Pippi Mod to reach level 60 to test if it would unlock. Then deleted the save files from the SaveGames folder and am starting a new game.)

Thank you, Ignasis for the Info and kind words. Thanks everyone else…

1 Like

Glad to hear you’re back and the issue is solved. Apologies for the mild frustration of getting it to work.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.