Endless loading screen

when i connect in game and chose my character, the loading screen appaers but the loading bar never goes up even after waiting 1 hour. The same goes when i create a new character. I’ve tried uninstal/re-instal but this keeps happening.
any suggestion ?

Did you do a full installation of the game, or was it the kind where you will have to download more information as you enter new instances/zones?

1 Like

Have you tried doing repair broken data from the options tab on the launcher?

1 Like

thanks for the advice, it worked !


This started happening to me too, like a day ago. I launch the game from win10 and from linux via wine-development, and it only happens on linux.

I’ve tried repairing resource data, I even deleted all contents of the RDB folder and redownloaded them, and usually the first time after any kind of repair the game would load, but any subsequent login ends with the loading screen.

When launching the game from console, no relevant error appears.

I’ve been running the game under Linux without problems for almost a year, so it’s weird now it stopped working. I haven’t changed anything on my end. This was happening both before and after the Equinox update.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.