Even more Game Pass issues

Just to make sure, I uninstalled the win 10 security update (!!!) to be able to start conan via game pass without crashing.
When I go into online play, I can see private servers but not a single official server. I noticed that when you start the game via game pass, it directly starts and doesn’t go to the launcher, also I can’t see battleye starting.
As battleye is part of the games distribution and works fine via steam, I am at a loss here.
Looks like the last patch screwed up even more than was obvious from the start.
Or are game pass users not supposed to play on official? :slight_smile:

Personally I think you have a blessing in disguise.

in what way? My son is playing via Game Pass, purchased Siptah and is not able to play at all.

Sounds to me like GamePass version isn’t using the right version. GamePass games frequently don’t update correctly (it’s not a Conan Exiles exclusive problem). Re-install the game is the only way to fix it.

1 Like

tried that, didnt work

Not sure what the solution for you would be then but if you don’t see official servers it means you are at least one version behind the latest. If you don’t run BattlEye you will still see the officials but you won’t be able to join any of them. You can post here the game revision number you see in the bottom right corner on the main screen to confirm.

This is the current version of the game:

it actually worked after the third reinstall, but last night window updatet the security update and now it runs into fatal error again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.