Exceptional Vanir Settler Breechclout - Mesh missing!

Game mode: Online
Problem: Bug
Region: America


I used a Level 3 Armorer Thrall to craft the Exceptional Vanir Settler Breechclout

Once equipped, the mesh is missing.

Steps on how to reproduce issue:

  1. Go to Armorbench
  2. Craft Exceptional Vanir Settler Breechclout
  3. Equip it.
  4. Mesh is missing

Noticed the same problem in patch before launch. I never posted about it though.
Also, they make the Vanir Settler Jewellry disappear from your character model when you equip the breechclout. Subsequently removing the breechclout does not bring them back and they’ll have to be re-equipped to show up again.

The regular quality Vanir Settler Breechclout works, but the version of Exceptional quality does not seem to be functioning properly. You still get the bonuses, but your character is running around pants-less.

I’m seeing the same issue now too. I was using this set all the way up until launch (TestLive build) and it was working fine. Maybe because I had it crafted before the patch that broke it, I don’t know.

This too. It actually makes any headgear turn invisible (tried with the antlers and sandstorm mask).
Does this mean we’re trying to wear breechclout on our heads?!

I use this set as my northern climbing gear. It’s going to be quite awkward scaling mountains now…

I just made the Epic Exceptional Vanir Settler Breechclout (geeze that name is long). These have the proper mesh and texture.