Fatal Error UE4 loading into a friends co-op game (no such issues for the first 2 days of play)

Game mode: Co-op
Type of issue: Crash
Server type: PvE
Region: EU
Mods?: No
Edition: Steam


Writing this up for a friend (I am the host of the co-op game). I feel I have all/most key info, but I can get more if requested dxdiag/logs/crash dumps etc.

Repro 8/10

I am hosting a co-op game, a friend of mine has been joining and we have been playing without issue for 2-3 days. Suddenly when running west toward the Unnamed City for the first time, following roughly 1 hour of playtime into the session, my friend crashed with a UE4 Fatal Error. This is our first experience of this in maybe 20-25 hours of co-op play across multiple sessions.

Now when loading into my co-op game, he crashes with UE4 Fatal Error 80% of the time.

Someone else who plays in the co-op session with us (on the same network as me, the host) connects and plays without issue.

Got my friend to pass his log to me, and it all seems to go wrong after pulling my Steam ID and attempting to connect:

[2022.01.10-14.19.25:810][149]LogFuncomLiveServices:Display: Parsed player ID Steam:“76561197974214664” from target URL “Steam%0A76561197974214664@fls.funcom.com//Game/Maps/Startup?Password=?bIsFromInvite?Ping=9999”, trying to use co-op driver.
[2022.01.10-14.19.25:810][149]LogPeerConnectionSocketSubsystem:Error: Dreamworld::FPeerConnectionSocketSubsystem::GetHostName is not supported.
[2022.01.10-14.19.25:810][149]WebRTC/PeerConnection: gethostname failed (SE_NO_ERROR)
[2022.01.10-14.19.25:810][149]LogPeerConnectionSocketSubsystem:Error: Dreamworld::FPeerConnectionSocketSubsystem::GetHostByName is not supported.
[2022.01.10-14.19.25:810][149]GetHostByName failed (SE_EADDRNOTAVAIL)
[2022.01.10-14.19.25:810][149]PacketHandlerLog: Loaded PacketHandler component: Engine.EngineHandlerComponentFactory (StatelessConnectHandlerComponent)
[2022.01.10-14.19.25:810][149]LogNet: Game client on port 7777, rate 25000
[2022.01.10-14.19.25:810][149]LogPeerConnectionSocketSubsystem:Warning: PeerConnectionSocketSubsystem::Private::GetLocalAddrFromOssSession: Unable to determine local endpoint name: No GameSession session found.
[2022.01.10-14.19.25:810][149]LogPeerConnectionSocketSubsystem:Display: PeerConnectionSocketSubsystem::Private::GetLocalAddrFromFirstLocalPlayer: Local endpoint name from player: Steam%0A76561198005849255@fls.funcom.com+7777.
[2022.01.10-14.19.25:811][149]LogWebRtc:Error: (peer_connection.cc:5680): AddSctpDataStream called when sctp_transport_ is NULL.

[2022.01.10-14.23.54:736][ 48]LogNet: UPendingNetGame::InitNetDriver: Sending hello. [UNetConnection] RemoteAddr: Steam%0A76561197974214664@fls.funcom.com+7777, Name: PeerConnectionNetConnection_0, Driver: PendingNetDriver PeerConnectionNetDriver_1, IsServer: NO, PC: NULL, Owner: NULL
[2022.01.10-14.23.54:736][ 48]LogLoad: TickWorldTravel finished. Time taken: 0.622919 [s]
[2022.01.10-14.23.54:736][ 48]LogSignalRClient: 2022-01-10T14:23:54Z: state change: disconnected → connecting

[2022.01.10-14.23.54:767][ 50]LogPeerConnectionSocketSubsystem:Display: Dreamworld::FPeerConnectionState::OnConnectionChange: Connecting
[2022.01.10-14.23.54:888][ 58]LogWebRtc:Warning: (stun_port.cc:426): Port[e213b050:0:1:0:local:Net[Intel(R):fdab:55f8:ee0b:x:x:x:x:x/128:Wifi:id=4]]: StunPort: stun host lookup received error 0

From here, it is a downward spiral resulting in an eventual crash.

We have both tried everything obvious both web and non web related on our end to resolve this but no luck.
Tried verifying game installs, updating drivers, rebooting machines and modems. I only use Windows firewall and cannot see any obvious blocks or conflicts, and although I have VPN’s installed for work, I am not using them.

BattleEye is not installed as we are only playing co-op.

I can send the crash dump along with the other info if desired.


Steps to Reproduce:

  1. Host boots Conan Exiles Live.
  2. Host selects Continue > Enable Co-op.
  3. Host press TAB + SHIFT to open Steam overlay and invite Client to Conan Lobby.
  4. Client Boots Conan Exiles Live.
  5. Client on the Main Menu, presses TAB + SHIFT and accepts lobby invite.
  6. Client attempts to load into the game and crashes shortly into the loading process.

Many thanks in advance for any help!

Hey, would love someone who understands more of the internal workings of the game to get back to me, we are pretty stuck otherwise.

Thank you.