Feeding pet or thrall system dont work


#1

Game mode: Online private
Type of issue: Bug
Server type: PvP
Region: german also english test on two testserver


Thralls and pets dont eat if i load any mod, also mods they have updated with new dev kit like pippi or emberlight


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. they get food in the inventoery
  2. Food Time left grow up
  3. but the icon in uper left corner finally is 0/100
  4. in Event log i can read pet is hungry, then pet is starving
  5. pet just dont starve why i set “StarvationDamagePenaltyCap=0”

this will be happend with 99% of all mods

Here my MOD-List:

  • Lvl 100, More Attribute and Feat | ID: 1369550768
  • SFXmod- soundFX for exiles | Mod ID: 1272719871
  • Condemned RP - Decor | Mod ID: 1437856038
  • Jungle Building Set | Mod ID: 1437122734
  • Savage Steel | Mod ID: 1367404881
  • Emberlight | Mod ID: 1369802940
  • IMMERSE RP & Building Decor | ID: 1394768794
  • Pippi - User & Server Management | ID: 880454836

#2

Did you try to disable all the mods. Does the issue still persist after that?

We are unfortunately not able help with mods directly. You will have to approach the modders in question about that.


#3

Works fine if you use mods, and only mods, that are compatible with the latest update. IMMERSE RP & Building Decor is one of those mods that has several issues due to a lack of compatibility updates. - Signed a Mod Author


#4

sure , without mods it works well, add one mod animal dont eat, you have to take a look on the sign in upper left corner


#5

i was also try with pippi mod and it dont works. pippi is updated with the last dev kit. you have to give attention to the sign in upper left corner in animal inventory. after the time it is on 0/100. so animal was never eating


#6

I wish I could help but as stated, we do not have any influence to code that is added through external mods. You are using them at your own risk as we cannot provide help for those.


#7

i know that, but it is a issue with all mods, please check it out


#8

the issue is when you use any mod, not a specific mod


#9

Just tried with my stuff, works fine. Went from 99/100, threw some food in the pet’s inventory, animal ate, 100/100.

I don’t know if Pippi has an issue with the latest hotfix (dev kit is not matched with the hotfix, only Patch 34 part 2), or whatever else mods (like I mentioned Immerse has a ton of issues atm), but it’s not a “all mods don’t work with the game” problem.


#10

Tascha, ich weiss Du sprichst deutsch, also vielleicht zum besseren Verständnis nochmal auf Deutsch.
Ich habe ale Mods aus meiner Mod Liste einzeln geladen und jedesmal war der Fehler derselbe, ausser beim Jungle mod und der ist nicht auf den neusten Dev Kit upgedated.
Der Bug tritt auf wenn man irgend einen Mod lädt. selbst mods wie pippi die auf den neusten Dev Kit upgedated haben. Das kann also nicht am update des Dev Kits liegen.
Ich weiss dass Ihr nichts mit den Mods zu tun habt, in diesem Fall jedoch muss es etwas sein das verhindert einen Mod zu laden, resp. sobald man einen Mod lädt versagt das Food System.
Sie nehmen Futter auf aber die Anzeige oben links sinkt weiter.


#11

i know immerse has more than one problem, but we have testetd on two server with different mods and is the same issue at all. i dont say all mods i wrote 99%. we also have one mod it works, jungle mod , and this mod is not updated


#12

Ah verstehe,
hmmm…ich kann das intern aufbringen. Ist auf jeden Fall erwähnenswert.
Danke!


#13

Vielen Dank Tascha, in der Zwischenzeit haben wir das gesammte fĂĽttern disabled :slight_smile: