Floating on stairs, ceilings, walls

Game mode: [Online Private]
Type of issue: [Bug | Performance | Misc]
Server type: [PvE]
Region: [North America]

[Character floating on stairs, ceiling, & walls]

On both DLC and base game walls, ceiling tiles, and stairs the character floats and falls on these pieces making playability very hard to almost impossible. THIS IS AN ONGOING ISSUE THAT NEEDS TO BE ADDRESSED AND NOT IGNORED!!!

1 Like

I run a private server for myself and a few friends with around a dozen mods. I have two machines i use to game on. The primary machine is a desktop with a direct ethernet connection. The second is a laptop with a wi-fi connection.

On my desktop machine, I occasionally encountered the floating issue at heavily overbuilt bases with lots of thralls until I moved the game to an SSD.
On my laptop, I still get the floating going on for a time after loading into the game. When i go to testlive with no mods, I never encounter the issue.

From what I can tell, this is due to a combination of: multiple mods, lots of game assets needing to load, restricted bandwidth, slower hard drives, slower GPU and CPU.

So, that being said, are you running multiple mods? Are you accessing the game over ethernet or wireless? Are you running off an SSD? Is your hardware restricting performance? Are the areas you encounter the issue full of assets and thralls? Does it go away after you’ve been in the area for a while (to allow the assets to fully load)?

1 Like

This is an old issue and has been reported many times.

The cause is latency.
For some reason the collision of the building piece doesn’t fully load when the character loads from being offline.

Somethings that can lessen the problem.
Don’t log out in your main base, it’s a good practice to logout out of render distance to your base.
I build a small 4x shack usually hidden.

While Mods can contribute to the problem they are not the whole issue.
I until recently, played almost exclusively on official pvp servers. They all have the this problem and only running out of render distance will fix it.

1 Like

Yes this issue is very annoying, happens even on 3x3 base far far away. appreciate the advice. What’s so frustrating is the machine this is happening to is a power house and the stand alone server that it is running on is as well, not to mention the network which handles and provides on average 980mbps up/down. makes me mad that my player base is running into this with or without mods. and that my wife’s own desktop is running into this issue. She blew away foundations until she no longer clipped into them. This bug must be addressed it is unacceptable from an IT/Engineer and Dev perspective that it persists so many years later, nothing irritates me more. Please for the love of all that is holy Funcom figure this one out.

This is not just a PC issue we have the problem on Ps4. Watching my wife play over the weekend she did a bit of floating in her base she was on official. On our private server over the last couple years big builds definitely affect this. Leaving render range and coming back does help. Occasionally logging out and back is better. Parity patch is going to fix .Every thing. Right?

Some Workarounds while this issue is fixed are :

  • moving the game from HDD to SSD ( greatly reduces the occurence of the bug )

  • Wait 1 to 2 minutes ( the Bigger the base you are loading in , the more you would have to wait ) standing still while everything loads around you . ( normally the loading screen is there for this purpose , not showing you that the game is loading all the assests of your base ect … but I noticed that it sometimes take shorter ( or longer ) time to show you the game ( and the faster it gets the more you’ll see things like your character inside a fundation 3 stairs undertneath where it should be , and teleporting back after a few seconds of loading where you disconected , you know those times where you log in and hear your character fall and break his legs !? ) If you just wait standing still , that all your decorations , the outside weather ( if it is sunset or sunrise ect … ) there is a small adjustment period where you see clear sunlight ( where a minutes or 2 later you see the actual server (night or day ) time ) then you’ll never Float on your building pieces anymore . ( I have the game on an SSD and always wait ~ 2 minutes , and since i do this i have 0 occurence of the bug anymore )

  • going out of render distance also fix the issue 100% of the time ( you just need to get out , and far enough that you actually see your building disapear , then come back in ( the better if you have a really huge castle would be to not run at full speed towards it while going back , but the floating bug shouldn’t occur anyways even at full speed )

  • people state that relogging works for them ( but for me it just comes down to moving or not too quickly as the game loads )

Anyways untill a proper fix , I hope those workarounds will help you understand the bug and avoid it the most you can :wink:

1 Like

Greetings @Kitty1286,

Thank you for your report. This is a known issue that our team has been working on.

In the meantime you can follow the workarounds suggested by @Kanza1.

Apologies for the inconvenience.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.