Follower not using Severed Arm weapon

Game mode: [Online Official PVP svr]
Problem: [ Bug ]
Region: [Europe]

[Free text] (but what did it do?)

Since the patch I have tried equipping a Severed Arm to an entertainer follower and they reverted to punch attacks only. I haven’t tried the other appendages yet since a rival clan wiped every one of our bases off the map and we are still rebuilding from the stone age.
I know previously there were issues with the Dead Leg weapon you can create from a Fragment of Power. That one really disappointing me since I grabbed a bunch of Cannibal Brutes only to find out they wouldn’t use it. I’ll try that out once I have the resources again.

Steps on how to reproduce issue:

  1. Equip severed arm to follower
  2. take all other weapons / tools out of follower’s inventory
  3. attack mobs
  4. watch as it tries to punch your foes with the tenacity of a Sargent Major seeing someone stepping on HIS lawn.

Hi @Gabe, thank you for reaching out!

We’re already aware of this issue and it’s being looked into, it seems to happen specifically with a few weapons such as the Dead Leg, Severed Leg and Severed Arm. Manually equipping these weapons to their hand slots seems to prevent the issue from occurring momentarily although it’s not an ideal solution.

Until the issue is resolved we’d suggest equipping them with weapons other than these, apologies for the inconvenience.

1 Like

Many thanks for the response Hugo!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.