Fps drop in Exile Land after the chapter 3

Since the last update on the exile land map my fps drop from 170 to 35 fps in certain areas of the map such as h6 (next to serenity of mitra) or f7 (under the aqueduct where the snake is)… I solved it. with a mod that eliminates the fortress of Al-Merayah and I didn’t have any more fps drops (siptah and the savage wild custom map work for me without problems)…I have also noticed that sometimes my gpu usage drops to 70% and my fps also that didn’t happen as regularly before the last major update…it would be good if they fixed the game so I could enjoy the new content without issues…

1 Like

Hello there @MrDownloop and welcome to the forums!

Thank you for taking the time to report this situation to us.

Just for clarification, you’re facing this FPS drop when playing without any mods at all?

It happens with and without mods… and I have already reinstalled the game

Greetings @MrDownloop ,

Thank you for your report. Please follow the steps to verify your game files:

  1. Open Steam
  2. In Library, click with the right button on the game and select “Properties”
  3. Select the Installed files
  4. Select Verify integrity of game files….

If the issue still persists, please feel free to reach out in private and share your logs with us.

Thanks in advance.

I have already verified the files many times…the problem was solved with a mod that removes the fortress of Al-Merayah…the problem is not the installation or my pc…it is the optimization of chapter 3… …

The specifications of my pc:
Intel i7 11700kf
32GB ddr4 ram
Rtx 3070 Twin Edge
2x M.2 NVMe SSD 1TB

Before chapter 3 I could play in ultra graphics between 200 and 150 fps in 1080p…