Frame Rate Issues

Game mode: [Singleplayer]
Problem: [Performance]
Region: [U.S]

I have vsync on and the game will run at 60 fps but will periodically drop to anywhere from 57-59 and then jump back up to 60fps in about a second but during that time the game stutters and it’s really annoying. It appears to happen more often when I’m sprinting or running around the world to new areas but it also happens less often if I’m just in my house and move around.

I have tried several things:

  1. Turning off Vsync
  2. Using Vsync in the nvidia control panel instead of ingame
  3. Setting Maximum pre-rendered frames to 1 in the nvidia control panel
  4. Updating my nvidia drivers
  5. Reinstalling my nvidia drivers
  6. Setting power mgmt mode to maximum peformance in the nvidia control panel
  7. Enabling low end laptop mode
  8. Turning off steam overlay
  9. Lowering video settings
  10. Turning off Gsync on my monitors
  11. Trying both full screen and windows fullscreen
    12 Turning Vsync off and limiting framerate to 60 or 80

None of this has helped.

Below are my Specs:

Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)

Processor: Intel® Core™ i7-6700K CPU @ 4.00GHz (8 CPUs), ~4.0GHz

Memory: 32768MB RAM

Card name: NVIDIA GeForce GTX 1080
Current Mode: 2560 x 1440 (32 bit) (59Hz)

Monitor Model: XB271HU
Native Mode: 2560 x 1440§ (59.951Hz)
Output Type: Displayport External

Game is installed on:

Drive: E:
Free Space: 784.2 GB
Total Space: 953.7 GB
File System: NTFS
Model: Samsung SSD 850 EVO 1TB

Steps on how to reproduce issue:

  1. Play the game and run around

So, any suggestions?

Was looking at resource monitor during these little drops, CPU usage hovered around 35 and didn’t spike during the drops.

Try these settings. I am running at 1920x1080 (HD 1080p). UE4 has A LOT of trouble rendering Pixel Fill Rates with certain parameters that we cannot discern with the human eye. It is simply how they use their ‘All On By Default’ Camera Post FX… and it appears Funcom is using it all by default. Great for ArchVis but tough on actual game play.

So knowing this I kept trying the drop downs Funcom has ‘Connected’ to the Post FX to come up with a really reliable combination. Also…keep that MAX FPS box Uncapped…not even sure what that setting is! It does affect FPS though badly.

Edit: Forgot…UE4 is a ‘Single Funnel’ processing since their UObject can only process 1 thing at a time (single threading). It is a severe limitation of the engine design. So having lots of objects running scripts can only be executed…1 at a time…animator as well. This is part of the stutter as well. Happens most often while I am around either of my houses. I play only SP now. Almost zero stutter while out and about exploring. Happens still though.

Hope it helps.

I tried and it didn’t help. I decided to to do a wipe of Windows 10 and erase all my data to see if that would work but unfortunately it did not. I plan to post a youtube video with an fps counter when I get a chance.

I’m going to try and use speccy to look at some of my drivers as was suggested in another thread.

Sorry it is not helping. That other thread ended up being not related to Framing at all…ended up being a router connection issue…which an FPS counter would not help with. If your FPS is smooth in Single Player mode then you have the right settings.

UE4 has very aggressive network positioning and if not set up right (by the dev) it will chew up a router. Also noting that Funcom is basically calling EVERY server available ALL at once in the server choose window. Epic’s UE4 networking is a really tough beast to change…meaning Funcom would have had to likely hire Epic to change it.

In early access I had to help a friend troubleshoot his server that was behind the router and he had lots of issues. Finally I told him to get a better router…like TP Link that has really good forwarding with clear rules and NAT. He finally did and all the lag went away…even his lag. I have the same router and run perfectly on my own private server.

Perhaps do a compare between SP mode and Online.

So i noticed one thing and that was that my GPU 1080 gtx was sitting at 100%. Whenever I’d get a framedrop it would drop to like 98 or 99% for a split second and go back to 100%

I wonder if thats normal

I’ve got a 1070 and I’m experiencing similar issues to you on official server. have capped fps to 60 and kept everything on ultra. Found 2 things to help it out. Actually half of my issues was when server crosses the 20 players online line. It wasn’t in my computer but server rolling me back small steps that gave the stuttering feelings. Well that’s not your case as you play offline but haply shared it.

I managed to heavily reduce the issue by turning down post processing from ultra to high or medium and keeping the rest on ultra. Still happens but way less frequent. Also when post processing was ultra it seems to get the engine to work poorly as after visiting relic hunters city and the black ship a couple of times even after leaving those places the game looses performance and start to get more frequent frame drops as you mentioned as buggy flashing water and odd shadows even leading to crash.

Edit: Funny thing is while it only looses 3-5 frame on those drops its noticeable as if it dropped to 45- fps.

Yes this is ‘normal’. It has to do with Pixel Fill Rate per frame. For example if the display freezes for a few frames the GPU has already drawn the pixels and nothing has changed so the GPU would certainly drop then pick back up once new information dumps into the buffer.

Yup exactly, which is why this triggers me :stuck_out_tongue:

I noticed that this does not happen in dungeons.

The game is actually fairly optimized and Dungeons do not have all the ‘extras’ to ‘fill’ the display with then layer them all to render them. You (Client) has to load all of them in as you come into view (called distance culling/LOD) which takes time to fill up the information attached to all of those pieces.

There are methods to pre-load this information but if something has changed in that mess you are seeing then it would require a new request for information. It takes time. The better the server connection the faster this is and the less ‘Load Lag/Stutter’ is experienced. Once the stuff is loaded to your computer (Client) then it is a matter of the culling system to begin rendering based upon your view distance setting.

Sorry for the long reply…but seems like your limitation is the server connection.

I’m offline single player though :stuck_out_tongue:

Ohhh! I see! :smiley: I went back up to have a look at your specs again…you have a stout machine. If you tried the settings I posted above and it is still doing it…then I have no idea. Has to be a CPU => GPU bottle neck. Nothing is overclocked? And the CPU and GPU are running cool? Make sure the setting is ‘Uncapped’ for sure in game settings. Tried to help? :grin::stuck_out_tongue:

I played last night for 3 hours and had no stutters at all. Every so often when I turn the camera really quickly I get stutter but that is my fault and the models are loading in.

Actually my cpu is overclocked to 4.5 or 4.6 from 4.0. Ill check out the heating when i get home and post that. And ill remove the overclocking on the machine.

1 Like

I don’t know if there’s any good info here. I didn’t notice any significant changes in the monitor during framedrops.


I unlocked my machine but the issue persisted. So i reclocked it found that my systen was unstable at 4.6 so i reduced it to 4.5.

I now real temp and cpu z going on to see if anything comes yp

It doesn’t matter, LoD an LoS is a rendering techniques, not networking. If your base is big enough and you have a lot of torches - it will add/remove light map every time it get out of render distance, also every destructible environment rendered separately from base map, which actually causes freezes on consoles

1 Like

The two pics you posted actually look good. It shows your system is running well and cool…I am assuming those are when the game is running. So no issues there.

Has to be a stability issue then when overclocking. To be honest, no need to really overclock with these newer generation CPUs. For example…when I built my game dev rig (which is also a gaming monster) I was particular to make certain that the Motherboard, CPU, GPU board frequencies line up well in a Powers Of Two compliment. I also made sure the Bios was the most stable version.

Since the Ryzen 5 1600 is stated to ‘Enjoy’ being overclocked…I tried it. It did get fast on Some things but overall many more crashes and much less stable. Then I set to task of running the fun but notoriously unstable Skyrim (Oldrim) heavily modded of course :heart_eyes::sunglasses: and could never go more than 1 hour when overclocking. Went back to no overclock and could easily run 4 hours before Skyrim became a Clogged mess. And in general this computer in high end game dev software, general use, and my game time all settled in perfectly.

Your computer is a small level above mine…but all in all…very comparable. So outside of the normal object rendering popping/stuttering we would expect from our building pieces and general landscape models you should be running as smooth and jitter free as I am.

So it has to be…either your Bios is not a stable version…or the overclocking is not in Powers of Two and you end up with a CPU => GPU bottle neck. Or simply overclocking is making things unstable when pushed hard. So as you play around…try to get your CPU and GPU is a Harmony Frequency Compatibility Range.

Other than that…I see nothing wrong.

Here are my specs from Speccy (free download)…prior to me adding my 2 SSD drives (1 for OS, 1 for Gaming)

Can you explain what you mean by powers of 2?

I’m and OC noob.

Sure. 2’s Compliment or Powers of 2 are math terms. Computer being math power houses always use 2’s compliment…Squares.

Example: 128 = 2^7 and 4k (4096) = 2^12

So why does this mind matter when dealing with Frequencies in computers? Simply because computer are 100% binary bytes (8 boolean 1’s and 0’s) which is directly built on top of the Operation of a Diode…raise the Voltage and the Diode closes to allow current (One)…lower the Voltage and it opens (Zero). So the frequency of the CPU and GPU are basically how many of these operations can happen in 1 second of time.

When doing computer and industrial controller optimizations it is extremely important to make the frequencies in harmony with each other. This cuts down on enormous reflections which basically bog down a controlled system. Many of the younger generation don’t really understand this and just ‘do programming’.

And finally…how does this apply to YOU and YOUR issue. hahaha!! Well…as I was saying it is important to make the CPU and GPU in harmony on their frequencies and that the Motherboard can appropriately handle those frequencies…AND…the DDR4 ram you have needs to be in that frequency range as well. It all makes the computer run much smoother and cooler.

Edit: Adding an example in layman’s terms as to ‘Bad Data Harmony’.
So you have your fast computer doing all the things it needs…at the frequency you set. Things that it only needs to do…great…do them and move along. Now it sees something that needs to go to the GPU…Great here you are…I am done with it GPU…you take it! Motherboard says…hold it…I am not ready yet (Cache) then tells the GPU the data is ready (Data Ready to Send)…GPU says…hold on I am not quite done…or GPU says…what took you so long I have been waiting! (Data Ready to Receive) Motherboard says…oh give it a rest here you are. See the bottle-neck here?

In a Data Harmony set up nobody is waiting on anyone. Data is fluid and the Cache is virtually empty.

If you want to optimize with a ‘Bench Test’ you can. There are free computer bench tests available and will show you where you need to adjust things. Companies like Asus do a really good job of optimizing right out of the box…others are hit or miss.

Hope that helps explain it better.
Note: I am a Systems Engineer (work deeply in industrial and computer systems to make them run well)

Here is a good wiki link on Powers of 2