Game crashing after Windows 10 Home build 1903 update

Edit: Please ignore my post. Problem happened again when I wasn’t even running the game or even tried it since boot-up. Guess its an overall system problem I have and nothing to do with the game. I’m sure I’ll come up with some solution somewhere… which will prob be a complete reinstall. :slight_smile:

Hi, I’ve been playing the game about a week with zero problems. A few days ago i got the windows version 1903 update (May 2019). Since then the game is randomly crashing anywhere from playing for 2 mins to 20 miins.

When I say game crashing, I’m actually getting the BSOD (although sometimes the background is gold not blue. 0o). The error message is " unexpected kernel trap mode", which seems so generic it’s nearly meaningless even after looking up details of it.

After the update I had not changed a thing, anywhere, and everything else on my laptop works fine, including other games.

Things I’ve tried to resolve the issue:

  • Used the game repair broken data
  • Made sure I have all windowsupdates
  • Completely uninstalled the game from Steam and reinstalled
  • Check Windows OS files are ok by using “DISM.exe /Online /Cleanup-image /Restorehealth” and “sfc /scannow”
  • Made sure all drivers are update.
  • Tried reinstalling video and audio drivers and DirectX 9 & 10
  • Disabled Windows Defender completely
  • Banged my head against a wall a few times

I run the game on default low settings on fullscreen. I only have a low spec laptop to play on, but it’s seemed to work fine for me for a week.

Specs are (try not to laugh :slight_smile: ):

Acer Extensa 2511
Core i3 5005 cpu @ 2.00GHz
4Gb ram
Windows 10 Home version 1903 x64
Intel HD 5500

Has anyone got any suggestion on what else I could try, or even whats causing the problem?

Any help greatly appeciated. :smiley:

I have this similar problem after 1903. Before I had casual crashes which become after recent nvidia drivers… I think. But now, it keeps crashing pretty much everytime when there is a lot of stuff going on, graphics heavy. I had some memory related statement after few crashes and I have runned RAM, VRAM and GPU stress tests without any problems. So, something fishy is on.

TSW is even worse, had crash loop in Fusang.

I run game with DX11, and turning SSAO off seems to be the trick.
In TSW, both SSAO and Tessellation off.

The game has been crashing like that for quite sometime now. Some say it is NVidia, and now the crashes are more frequent (I crashed three times today in less than 10 minutes) some are saying it is the Windows 10 update. Each time it crashes it sends me back to the desktop. Annoying as all hell that’s for sure. Watching a streamer on Twitch play the game it crashed on him several times as well. What was unfortunate was that it was his very first day playing the game! What gives Funcom? As far as myself doing self diagnostic, and adjustments to my PC to correct this situation forget it. My other games play just fine.

1 Like

I tried lots of tricks, and could not get stabile run to this game. I noticed that if you dont have any addons, it does not crash that much. But I gave up, I dont play games what does not work well with modern technology.

1 Like

I had the exact same issue with the latest Windows 10 update.

The problem was actually Geforce Experience. When I upgraded my version of Windows, GE decided to update my graphics drivers from the version 425.xx to 430.xx.

It’s a know issue, since the 430.xx version of Nvidia, SWL is broken.

You have two possible solutions :

  • You can play the game in DX9, it works. Even with latest Nvidia updates. But the game was optimized for DX11 and it still might crash from time to time (won’t be that random though, DX9 usually crashes at loading screens and when there are too many effects on the screen)

  • The ideal would be to run the game in DX11.
    But to do so, you have to completely uninstall everything related to Nvidia
    (I had to use this tool to perform a clean uninstall : Display Driver Uninstaller)
    Then, download the version 425.31 of the display driver from here : Nvidia Driver Download
    And install it - you need to check “clean install” and uncheck Geforce Experience.