Game Crashing upon equiping an armor piece

SP- PC-PVE- NO mods

My game has already crashed 4 times upon equiping an armor piece to my character. This does NOT happen Always though.
There must be sthing wrong with either the attributes or the textures display.

Other than that, the games runs just fine

Regards

In support of gathering information for the devs, what, specifically, is the armor name and piece that is causing the crash?

I can replicate your actions and report back here.

Regards

jim

Doesn’t matter which armors, i think.
it happened with any legendary items looted in the unnamed city (like the red dancer corsage for ex) it has also happened with light vanir and dafari gear.

The issue is happening by Simply double left clicking on the item (even if you’re naked) and even by right clicking on the item.

Then when you log back in you find your character with “duped items” : the one you were trying to equip upon the fatal error is now equiped on your toon while you have the exact same piece in your inventory and none of these pieces are “ghost” pieces, i checked.
Both pieces are true armor pieces that will give you attributes/ temp resist, the same durability it had upon crashing and even the nice colors you used to dye it.
This seems to be a pretty recent bug to me.

1 Like

And a bug unknown to me. Early on, I thought double-clicking an item was the only way to transfer an item from one container to another, or dragging it across which is subject to dropping it.

Somewhere (probably here), I leaned to shift-click the item for a transfer and have been using that ever since. The only exception is when I transfer armor from a thrall’s inventory to his equip slot. Does it happen then?

Regardless of your answer, let’s go to the basics.

Could you verify your local files through steam? I wrote a short guide here if you have not done that before.

Regards

jim

If you use right click on an item it will automacly equip it to your char and put the former equiped one in the slot of the one you’ve just equiped (very convenient for armor pieces)
Try it if you have not already.

1 Like

Thanks, I will !

Regards

jim

1 Like

And it works on a thrall interface, too, his inventory to his armor slot. You just made my day :slight_smile:

Regards

jim

1 Like

@Jim1 Right-click is how I equip armor to my thralls directly from my character’s inventory. Saved a lot of time when I learned that.

Also don’t feel bad, I only learned yesterday that we can hold Tab to inspect a building’s info instead of having to use a repair hammer. :sweat_smile:

4 Likes

Wow, I wish that would work for me ! That’s a really good one.

Unfortunately, due to using a Logitech G510, I bind tab to autorun and would end up with a flat nose.

Thanks, may have to rethink my bindings rather than go get a hammer, start looking through it, checking stabilities, stash my hammer somewhere I will forget …

Regards

jim

PS: I saw a video somewhere, bet you did, too :wink:

PPS: Bound autorun to capslock, tab now available. Chat may look a bit funny coming from me to global …

1 Like

LMAO, I can see it now…

Jim1: WELL HELLO THERE, NEWBIE
Noob: Aaah!
Friend: What’s wrong is someone stealing your stuff?
Jim1: NO I’M JUST SAYING HI TO A NEWBIE!
Noob: …
Jim1: DON’T BE AFRAID
Noob: I… should probably move, huh?
Jim1: I HAVE A TIGER IN MY POCKET FOR YOU. HERE, GRAB IT.
Noob: Stranger danger, STRANGER DANGER!
Jim1: WAIT WHERE ARE YOU GOING, I’M JUST BEING FRIENDLY…
Noob deletes character, crying profusely
Friend: Jim, buddy, switch to decaf!

1 Like

tRIED DECAF, SLEPT A LOT.

rEGARDS

JIM

1 Like

Didn’t no this one either, THANKS !!!

1 Like

If you manually, not use the quick clicks, does the game still behave badly?

1 Like

good question.
The crash is pretty rare though, i would say it happens 1 time out of maybe 5 times i equip an armor piece, which you well understand i only do when switching from a biome to an other one. So it’s hard to find out unless i force myself to use the “drag item” thing from now on ( assuming this is what you meant by “not use quick clicks”)

Anyway it’s not the worst bug i have ever seen but the devellopers should still have a look into it imo, especially since it can allow players to duplicate items like legendary armor pieces from the unnamed city for ex.

2 Likes

I was thinking of the “drag and drop” method does not cause the crash, the problem would be in the quick click movement. Knowing this would help the developers focus in on the cause.

I use the same lame armor always, but next time a gain a moment to play, I will admin various items to see if I can crash my game. Having the opportunity of others to reproduce the issue will also help find a cure.

3 Likes

omg, i got the same, this one is a nasty bug i cant get into here, i am making a report :slight_smile:

Hey @roro4066

After reading the whole thread we would be grateful if you could clarify some details before we relay this info to our team :slight_smile:
You mentioned this crash happened when equipping any armor, but a bit later you seem to specify that this armor comes from the Unnamed City. Is it then happening when using legendary armor?
Also, the way you equip this armor from your inventory, could you specify it as well so we can try to isolate the issue?
Finally, as a side note, have you tried verifying the files on Steam just in case there was some corrupted file somewhere that could cause this?

1 Like

This is correct.

yes

There is not just one single way.

  • You kill a boss you find an armor in his inventory, you directly right click on the item from the boss inventory.
  • you Simply are ready to use your maproom to an other biome, so you put yourself naked as it’s pretty cold at the mounds in dafari gear, you wait untill the very last moment before equiping your heat resist armor, and then once you do (Simply by double left clicking on the item), no matter which piece, you crash and duplicate the same piece.

Yes sorry, Jim had asked me the same and i think i forgot to answer (sorry jim)
Of course i did, Always the first thing i do when i encounter a problem.

2 Likes

Thanks for the thorough confirmation @roro4066. Sending it to our team :slight_smile:

2 Likes

I’ve been Following Shadoza 's suggestion since my last crash and i haven’t encountered the issue anymore.
So it might be the fact to use “double clicking” which messes up the thing, i Don’t know…. hope it can help you guys figure it out.

I’ll come back if the issue shows itself back.

Regards

2 Likes