Game hangs at zoning screen

I have played SWL since day one with exactly this PC setup with no problems at all and the PC is kept clean with minimal installations as it is only used for gaming. I only had a few crashes and the infamous NY raid crash, no other issues with good performance and fast loading : i7-4770K, sabertooth, 16 gig RAM, Geforce GTX 780, Win10 64 Home.

Suddenly last wednesday (maybe it was after last servr restart ? not sure) I logged in and I could not zone into Dark Agartha, I got to the zoning screen but nothing loaded and even waiting for several minutes I never zoned in. I had to alt-tab and kill the game to log back in.
This is now happening randomly 20 to 80% of times I try to zone with no apparent reason. While in a zone I can play normally, no lag, no strange crashes, nothing.

As I said nothing apparentely changed on my side so I was wondering if this is something someone else experienced and if there is an easy fix for it before I try to disinstall and re-install the game (already tried the reapair data a few times).

The only doubt I have is that in the last month I had a noisy fan and maybe it could be an overheat problem, but can’t see why it should cause problems only when zoning. Anyway I will get myself a new fan and change it in the next days … Should I check the intergity of any other PC component ? I checked the SSD but maybe memory ?

Thanks in advance for any help

You’re not alone. This is happening to me also, and I know for a fact I have no heating issues. I run a NVIDIA GeForce GT 740 which has never had any issues until night before last. (12/7/18). Dunno what’s causing it, but zoning once, forcing the game closed, reloading, zoning once, forcing the game closed, reloading over and over and over and over and over is just not going to work.

Dunno what’s causing it cause I’ve literally changed nothing software wise, other than a few text files on the desktop.

I would also welcome feedback on how to resolve this. I’ve ran SWL’s repair tool, defragged the drive and rechecked all of the existing startup and system tray applications to see if anything changed / was added and there is absolutely nothing, which inclines me to think it’s something on FC’s side.

Often, this is due to unstable connections to the game. Try logging in through a VPN and see if clears up.

Relatedly, there has been some really bad latency to the game servers for me over the last couple of days. Not sure if it was on the server or if some outside routing issue near to the game server, but it was bad the other day. It’s mostly ok now, but still getting some latency spikes.

You know I wondered about that, but it’s not the issue in this case. I run a dual monitor setup and put a latency monitor on the second screen to observe. Additionally I turned the ingame one on, and observed. In most all cases the desktop mirrors the ingame one. And even with low latency it still happens.

I should probably also mention that I have one of if not the fastest internet connections out there. My ISP is EPB which deployed a fully fiber-optic network in my city, making us the first “Gig City” in the USA. At present, I have one Gigabit up AND down.

Obviously that doesn’t help a whole lot if something is screwy somewhere in the middle, but it’s at least some indication it’s not my PC nor my internet connection anyway.

A latency monitor isn’t the best indicator unless you’re constantly pinging the game servers IP directly. Latency monitors also don’t inform you of packet loss which can also lead to disconnects and hanging loading screens.

It’s just something to keep in mind.

1 Like

Sounds like connection problems somewhere in the internet may be the issue as this evening is getting even worse : sometimes when relogging I cannot even reach the login/authentication server, then suddenly it works like a charm.

Ofc I tryed to disable the firewall but with no result.

BTW I am playing from Italy

If you’re playing on multiple screens, one thing I’ve observed is that the game is more likely to crash if you switch away from it during the first part of the loading screen (before it makes any visible progress on the bar) Happens especially with Kaidan because it takes a long time to do that part.

I’m sorry to hear about the trouble some players are having in this thread. Unfortunately, I don’t have a ready answer for you as there are a number of things that could be at play here. We’d be more than happy to do some troubleshooting for you through Please consider contacting us through this website to start a tech support email.