God Token. Yamir Takes 5X why? Xbox

Game mode: [Online | Multiplayer]
Problem: | Misc]
Region: [NA]

[why is that for Ymir we need to harvest 5 times the amount of humans/NPC to get coins? Is it intended or a bug?]

Steps on how to reproduce issue:


Yamir was intended to be a “peaceful” religion, the ice shards we’re to be harvested from trees. When the religion was turned to murder, it was never revisited for rebalance as of yet.

1 Like

Hello, Yes I agree Ymir altar should be revised. The cost to upgrade the altar is way to excessive. Hope they change it soon.

I must agree with this. And Im a player who is tired of the costant nerfing and rebalancing where it is not needed. If it is one lingering essence, human heart or unblemished flesh per manifestation of zeal, then why does it take five ice shards for one manifestation of zeal?

As a follower of Ymir I also agree.

I searched all over because I got no shards from trees. Now I find out it is supposed to be bodies, but it does nothing to them. Just swing and swing with no result or effect on the bodies. I hope this is fixxed soon. I broke 3 hatchets trying to get the darn things from trees, now it will not work on bodies either?

You only get a one shard from each dead body when you hit it with the axe.

I have also found the hoar frost axe fails to connect with dead bodies meaning i am unable to collect any ice shards. This is extremely frustrating as I chose Ymir as my primary religion and don’t want to change to something else. Also the same problem exists with the steel pickaxe - it fails to connect with iron, rock and other mineral deposits unless you can position your character on a lower angle than the target. It seems that the pickaxe animation/mechanic is locked into axe/chopping trees mechanic. It is also very frustrating as it means I still have to carry a separate pick to make sure I can gather all the iron/etc resources in an area. But it is not half as annoying as the fact that my hoar frost axe is completely useless and just flies over the top of dead bodies without harvesting any ice shards. When will this bug be fixed?

Ok thats odd. @GrenzerKuk I know that harvesting the ice shards works for me currently. I even checked it out to be certain. This may sound like a silly question/idea, and Im not trying to be impolite here, but have you tried manipulating the view like I do? When you are ready to harvest the body, simply move the camera so that it is positioned above your head (birdseye view), and you are looking downwards onto the dead body. This alters the trajectory of the swing. It works for me every time.


Could be interesting too if they added a feature where if you did a killing blow with the axe, the person you’re attacking turned into an ice statue. Then, when you harvest with the axe, they shatter and give 10 ice shards once instead of the normal drops.


this was literally going thru my mind as i got to your post on the thread.

1 Like

Going a bit off track here. When I read this I immediately had the following run through my mind:

"Sub-zero wins…FATALITY!!
(I like Mortal Kombat :slightly_smiling_face:)

1 Like

+5 entrails
+10 ice shards :stuck_out_tongue_winking_eye:

1 Like

Yes, I love it @Aaron! I used to play MK in the arcades when it first came out. Still playing on console too. To me (others disagree if you wish) it is one of the founding fathers of video game violence.

Ps- ice shards and all we need for mystery meat soup; how could one go wrong.

1 Like

Thanks for your response. I have tried doing what you suggest, moving my camera POV until it is looking almost straight down on top of my character like a drone, but still can’t make the frost axe connect with the dead body. I know with the pickaxe I often have to fiddle about with the angle of view to get it to hit low-rise rocks (and even then I still get some instances where it just won’t hit the damn rock whatever angle I come at it) but it doesn’t seem to matter how much I fiddle about with my POV for the frost axe it just won’t connect. So while I can (sometimes) get results with the pickaxe by altering the trajectory of the swing nothing I do re the swing trajectory of the frost axe is making any difference - it just won’t go low enough to connect with the bodies. Maybe its a serious lack of hand-to-eye coordination on my part but even if it was I think funcom should come up with a much more intuitive and much less glitchy frost axe mechanism than is currently the case.

@GrenzerKuk No problem. Yeah I agree, it shouldnt be that fiddly to line it up, especially if you are already angling directly at the body. It does indeed sound like a bug. What a horrible one too; that virtually renders one religion entirely unusable. If you have not done so already, I would strongly advise that you post this issue on its own in a new thread. Heres hoping it gets sorted soon.

1 Like

Sounds like you two are suffering from the vertical aim bug. It’s a known issue, and I’ve frequently experienced it myself. Basically, your character stops being able to aim up or down, which makes hitting bodies or rocks or something else laying on the ground rather tricky. A good test for it is to go into first person and look down. If you’re on a female character and see boobs, you’re good. If you see through boobs, you’ve got the bug. If you’re on a male character and see boobs, see a doctor.

Fortunately there is a workaround. All you have to do is die. :smirk_cat:

Plop down a bedroll and remove your bracelet. After that, it should start working properly again. I usually only have to do it once per session when the bug hits me.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.