Hazy shade of Conan

I’ve pointed this out before so am still waiting for a fix. Been all over my graphics settings, set reset, tried again, nothing fixes this constant haze, fade, and lacking of resolution. 1080, full screen windowed, all ultra but AA which just makes it worse.

Now I used to be able to do further adjustments through my nvidia card but that option has apparently been removed/lost. Really crispened it up nice. Like putting on glasses.

Going to full screen; unwindowed, makes it marginally better; and a slim margin.

I know I’m not the only one having this issue so it has to have been bug reported, but…

How big is your monitor?

A certain amount of haze can be reduced disabling Volumetric Fog in settings/video.

The Nvidia setting is here:

Done it. Like I said I have tried everything and that is as good as it gets. This is something they need to fix; note that it is not near as bad on siptah.

Tried using Reshade (GeForce experience has Reshade filters built into it)? And if there is any confusion, yes Conan is compatible with it

Used something like that years ago on LOTRO, worked great. I’ll give it a go because I swear I keep wanting to clean my glasses and wipe off the screen lol

Edit to add WARNING do not try reshade. Not compatible with battle eye and now I got to play hide and seek to get this off my comp because I can’t play Conan right now. And can’t find reshade to shut it off or uninstall it.

Ya, had to do some deep folder diving to remove this.

I used the filters via GeForce Experience (ALT+F3) and had no issues with BattlEye.

1 Like

You could try looking here:

1 Like

What Narelle said. I specifically mentioned the built in Reshade with GeForce Experience as I know that works with Battle Eye.

I have also used the manual installation method years ago, but no idea if that will work with Battle Eye.

Used to work but I lost that with a card update a while back; as well as a few other functions.

Just made it worse, but gave me ideas to try.

Fixed more or less. Redownloaded and reinstalled GeForce Experience. Not sure when it got uninstalled but sure it was during a graphics diver update.

Still not something I should need to use a graphics filter to fix.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.