Healing Arrows visual FX

There is a problem with the healing arrow FX after the latest patch, its missing. There is only a tiny water spash where the arrow lands, but no purple healing mist effect is gone.

The area healing is still working, but its currently invisible as it is.

Hey there, Asteria!

Could you give us a little more information about this issue? Are you on an offline game or an online server? Could you also give us a little more information about your setup? Is there any screenshot you could provide us with?

As a general, quick fix, have you tried to update your drivers?

Thanks in advance!

I can confirm that the official online servers have the same issue. You Will see a splash but the healing mist is no longer present.

Yes sorry, I play on officials, NA, PvE server.

The old healing arrow FX always worked, but just like Hexsing also confirmed, there is just a small spash effect (where the arrow hits) after the update. The gas is invisible but still there, we are effected by it.


Thank you for the confirmation and for providing some extra helpful details. We have informed the dev team so they can investigate the issue further.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.