HELP. How do you activate the journey steps please?


I need help regarding the journey steps.

I am offered the option to skip them, but there’s no button to activate them.

Somehow, I managed to complete ONE of them when the button to “skip” the journey changed into a button to activate the journey (don’t ask me why or how, I have no idea :scream:), but that’s it.
The other buttons do not offer the option to activate the journey, I am at a loss.

In despair, I tried completing the tasks of the journey without the magical button, but it is not working.
And in case you wonder, whatever needs to be unlocked in the knowledge menu beforehand is already unlocked.

I tried logging off and back in, nothing changes.

What am I missing? Any piece of advice is welcomed :cry:

Open up your journey dialogue.

Look and see if there is a red bold border around one of the selections. If not, then you don’t have any steps active. They wont trigger unless active.

Choose one (make it active). Follow the first step. If it works, you got it.

1 Like

Oh my, I think I found the solution by watching youtube videos. The text in the video is in English, so I have to test it out, but I might have a lead on what to do.
The “skip” button might not be one O_O

Thank you so much Dzonatas!

The coloured border was indeed the issue! I did not realize at first. I have to click on the skip button to actually “select” the journey as the one I want to follow.

Thank you for your help!

1 Like

I have the problem, that the first one still has a lock on it. that where you would learn the basics and i have the problem to make or get a poison bottle within the rogues chapter. i am to weak to kill a “sandechse”.

Funny thing is, most people have said the journey system helps new players, and yet here we are having to look on YT to learn how to do an instruction manual. LOL.

1 Like

Its contents helps the new players, but the mechanics can always be improved lol.

In my case, I got confused because of the language. In my game, the button to launch the journey could imply that we’re asking to skip/change of journey, full stop (in a similar way that we can skip/change tasks to progress in the battle pass).

1 Like

I appreciate how the new journey system actually tells you how to complete a journey step. It’s just the UI that may be confusing to some.

1 Like

Actually, amending my opinion somewhat:

There are some journey steps that require you to craft something. These actually complete only once you pick up the item from the crafting bench. It doesn’t even have to be an item you crafted - I got the “craft iron reinforcements” Step to complete by storing some iron reinforcements I had looted from Purge enemies into my blacksmith bench, and then withdrawing them back to my inventory.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.