Help unlocking Apprentice Mason

Level 4, have 2 available knowledge points, select Apprentice Mason (requires only lvl 3 and has no requirements), unlock(1) displays but single clicking, double clicking, pressing F and switching to controller and pressing A does nothing… Can’t seem to unlock any knowledge. Tried reloading, tried creating new character. Do you need to be somewhere specific? Anything else needed?

No, if you have the available knowledge points and you unlock the skill then you need to craft a construction hammer and equip that in order to be able to build (construction hammer is crafted from the inventory panel with 20 wood and 5 twine)

After equipping that, that’s when you get access to the construction menu and can use F to select pieces, right-click to go into delete mode and middle-click to copy an existing piece without having to reopen the menu

Issue seems to be I can’t unlock the base skill. I “think” I should just be able to select Apprentice Mason then double click to unlock it, which would teack me all the associated patterns under it. Clicking does nothing and i"m not getting access to the crafting patterns. I did try making a construction hammer before trying to unlock the Apprentic Mason again but no joy…

Can you maybe post some screenshots so we can see how it looks on your end?

Yes, level up by killing or harvesting.
At level 10, you can start building a base and benchs :slight_smile:

I’ve had a similar glitch with unlocking feats occasionally. For me, exiting and re-entering the game has thus far always worked.

Obligatory questions:

  • Do you have any mods installed? Those can sometimes mess up the base game.
  • Are you playing on official or private servers or Single-Player?