Hunger / Thirst Bug (doesn't reduce after reaching maximum)

Game mode: PC Single Player
Type of issue: Major Bug
Server type: Local Single Player
Region: From Game Start

From researching, it looks like this bug has been reported going back 3 years, across multiple platforms, recently (this month) a reddit user reporting it on PlayStation.

It’s very reproducable, in that once it happens your game is completely broken. It reproduces EVERY time. But I can’t definitively say what makes it happen. Note it’s been reported by users with modded games (like me) and unmodded, cross platform.

What happens is, the fundamental survival mechanic, hunger/thirst is broken. It probably affects more players than who report it, but people for whom survival is not important part of the game just don’t report it.

When your thirst or hunger reaches 100, it STAYS THERE. It does not reduce, regardless what settings the game has for hunger/thirst. No server issues, no setting issues, single player game, with the survival mechanic turned on.

Hunger and thirst OPERATE NORMALLY until such time as you reach 100 satisfaction in one or both at which point they stay there and do not reduce.

Thirst can get stuck at 100 while hunger mechanic continues working normally, if you have not increased food intake to 100 but once you reach 100 hunger will not occur either, the number doesn’t reduce it just sits at 100.

It’s a fundamental corner of the game, and this mechanic being broken makes it unplayable for me.

Note - did a full uninstall and reinstall 35gig or whatever it was. No joy. Removed all local content, cloud saves, completely fresh clean start. No joy. Ran it initially with no mods (clean start), no joy. Tried again increasing hunger/thirst settings in custom game setup. No joy. Tried again with my preferred workshop mods, no joy.

In each instance, this bug occurred as soon as hunger or thirst reached 100.

Please look at this, thank you.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Run game
  2. Collect waterskin, drink til empty, thirst reaches 100
  3. Note thirst does not reduce **
  4. Obtain food, put hunger to 100, hunger no longer reduces

** note, I did watch this very closely, there was one point where thirst DID reduce, sitting idle, it went from down to 98 or 99 (don’t remember) then momentarily after, it went back up to 100 (with no player interaction, just watching the stat sheet)

Really weird glitch please fix.

If you reach 100% the time it stays at 100% is longer than the time difference between each % drop. But staying there for a long time and even getting up with no reason seems wrong.

Thank you mate - I can confirm that after hitting 100% it’s not just a “hang there longer” scenario, you can let the game sit for a half hour and come back and numbers are still at 100.

What I’m guessing is that if there was a change to have the 100 level ‘stickier’ (ie when satisfied you stay satisfied longer), someone in the factory pulled the wrong switch and in certain obscure code situations it can become wrecked.

I personally would prefer harsher survival, not easier - I read somewhere swimming no longer costs stamina ? Total side comment, but not a fan of any changes that decrease the survival difficulty … but thanks mate, yeah I understand the point - and it’s definitely not that, it’s uber screwy.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.