Isle of Siptah Accursed Bearer T3

Game mode: Online private
Type of issue: Bug/Other
Server type: PvE
Region: EU
Mods?: Yes
Edition: Steam

Bug Description:

Accursed bearer T3 thralls on Isle of Siptah seems to be equal to T2 bearer thralls from the other groups (Stygian invaders, black corsairs, exiles). The most obvious thing is that the Accursed bearer T3 has the same (lower) number of inventory slots as other T2 bearer thralls. Hit points/stats also seems to be lower. I have tried with several Accursed bearer T3 and all exhibit the same problem. Is this WAI or a bug?

Expected Behavior:

I expected the accursed bearer T3 to be better than or equal to the other T3 bearer thralls, but I actually got a T2 that is named T3.

Installed Mods:

  1. Pippi - User & Server Management System: 880454836
  2. Fashionist: 1159180273
  3. Glass Constructions and more…: 901911361
  4. Dudes delightful decorations: 1934607107
  5. Primal Armors: 1427509507
  6. Immersive Armor: 1966733568
  7. Barbarian Barber: 2050780234
  8. Better Thralls: 931088249
  9. LBPR - Additional Features: 1444947329
  10. LitMan Item Stack & Container Size: 1125427722
  11. Hosav’s Custom UI Mod: 1797359985
  12. Waystones: 2424793128
  13. Kerozards Paragon Leveling: 1629644846
  14. Pickup+: 864199675
  15. Less Building Placement Restrictions: 1369743238
  16. Emberlight: 1369802940
  17. IMMERSE RP : Buildings & Placeables Decor: 1394768794
  18. Savage Steel: 1367404881

Steps to Reproduce:

  1. Go to the accursed citadel or any other accursed bases where bearer thralls are found (I always seem to find at least one bearer T3 at the citadel).
  2. Beat him/her senseless with a truncheon.
  3. Drag him/her back to your base.
  4. Put him/her in the wheel.
  5. Wait until the thrall is broken and ready to start a new career with you.
  6. Open the thrall inventory and find 15 inventory slots when you expect 20…


Edit: After seeing replies here about adminspawning I tried admin spawning an accursed bearer III (heirs of the north surge sherpa 3 nordheimer2). That seemed fine, a completely normal T3. I then again caught a T3 on landscape and it, again, seemed like a T2. Then I adminspawned an accursed bearer II (heirs of the north surge sherpa 2 nordheimer2). When placed it is called accursed bearer III. So the T2 is in fact mislabeled as a T3 on landscape.

1 Like

I wanted to test this out but I could not find any accursed bearer in the admin panel to spawn one in. Could it be that it is added by one of your mods?

1 Like

Thanks, Zeb. I didn’t think of looking for it there.

I spawned both of these and they both seem the same:

Also in terms of stats:

Here is an invader one:

All looks fine for me in the base game so again, perhaps one of the mods messing with them?


Dont use accursed bearers.They is low on hp too.Free from cages-there is true t3

I will try spawning them as well when I have the time to log in but it does seem like there might be a mod issue here.


1 Like

I Admin spawned one of the (Sherpa_3) Accursed Bearer III, it appeared as expected.
I located one in the wild, captured, and tamed it, but it appears as the OP stated. 15 slots instead of 20.
Then I admin spawned a Sherpa_2… it is mislabeled as a Accursed Bearer III in inventory and when placed.

So, I believe that is the issue. The Sherpa_2 Accursed bearer is mislabeled as a Accursed bearer III. The Sherpa_3 Accursed Bearer is correctly labeled.

Edit: tested on Test-live, single player, no mods.


Thanks for this :slight_smile: I was just about to make a post about it. I got exactly the same results as you did. I have made an edit to my original post.



Good catch.


I reported this same bug months ago in the Xbox forum’s!
I am on Official PVE.

Now we have identified why this is happening. It is possible that the devs couldn’t reproduce the issue when it was reported.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.