Isle Of Siptah game breaking bug

Basic Info:

Platform: Xbox Series S
Issue Type: Crash
Game Mode: Online Official
Server Type: PvE
Map: Exiled Lands
Server Name: 7002

Bug Description:

Every time I load into the server I play in my game crash.

Bug Reproduction:

Moving into certain parts of the map i.e F5 causes the game to freeze and then crash

1 Like

Same, just played with a friend on our server from Gportal and he can literally not load in now. I somehow managed to “escape” the freeze trap by loading inn and not look at that direction and admin teleport away. He has Xbox X, myself Xbox S

Edit: For us it is G6. We started the game at O10 if that matters

Edit2: to other ones seeking a possible temporarily fix, my friend solved it by holding the stick while it loaded in so he would look down on the ground when entering the game. Do not look up! This worked. Do this and use map to direct yourself to get yourself killed or out of range where it struggles to render.

The same bug on my Xbox SX. Nothing helps to solve it. Isle of Siptah crashes every time after save loading and moving around.

Same here Xbox Series X on map 7071


Thank you so much for your report.

I reported this issue and we will try to investigate it as soon as possible, meanwhile, we appreciate your patience.

If any more information pops up, feel free to reach out to us.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.