Language settings are not saved correctly


#1

The game automatically picks the system language (German in my case). I try to set it to English and it seemingly works. But when I quit and reboot the game, the language is German again.

Please advice.

Cheers,
Simon


#2

I can confirm this.

Mod edit: removing unnecessary commetnary


#3

According to the devs, this is a known issue. We’ll get that fixed in a future update; thanks for the report. In the meantime, you can work around this by using Launch Options.

(https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947)

Under Launch Options, try adding the line “-culture=en” without the quotes to force the game into English mode. Let us know how that works!


#4

Is there an option to force subtitles?


#5

-culture=en does not work for me

This worked for me:

  • Put the above into the launch options
  • Changed the game language from english to german (game language was german regardless of english or german was set tho)
  • Changed it back to english: Game was still german
  • Changed the language to spanish
  • Changed it to english: Voila, game was english now