Missing Watcher Stuff/Stream Rewards

Hey, so I submitted a ticket a few days almost a week ago. My ticket was put as solved even if the issue is absolutely not solved. I reposted it and no response and tagged it as resolved yet again but issue remains. So now I am posting here.
In my bug report, I posted with proof that I have watched and was able and have also claimed all the Watcher items from your Twitch Stream giveaway thing you did a while ago. I have used these items with success many times but after 3.0 they are not there for me to craft or spawn. Friends of mine who play on the same server as me have no issue getting their Watcher items from either spawning or crafting. So this is absolutely not a server issue, this is an issue that needs to be solved as I absolutely have the right to all those items that I watched streams for and claimed.
I am seen here as a new user so I can not upload the images to show the proof of the fact here, but I have the image proof and they were also sent as I said in my ticket I sent prior to this post.

Please help me get this sorted

I know the Watcher items were disabled for a period prior to the release of 3.0 but once that came out they were re-enabled. So, it is definitely not a server issue. Have you attempted to un-link and then re-link your twitch account to your game? I am not sure if that will do anything for you, but you could give it a try as it might trigger your account to “remember” that you have access to these items. Other than that I am not sure.

I have not tried that. I will try that and see if it works. I was afraid to do so in case it would mess things up.

did it work?

Sorry for the late response.
No, I just tested it and it is still broken and I can still not get the watcher items :frowning:

I have the same problem the watcher item are all show up in the feats but i dont can put points in too unlock them

You have never need to put point into them or unlock them. That has never been a thing. Have you gone to an artisans bench or a armorers bench and looked for the items there?

Yes no option to craft them in my feats they are looking like other recepies brown like you need spent points on them but it not work

It happened to me as well, I went on my twitch account and disconnected it from funcom, you should find this option on twitch, then I wait 24 hour and linked it again. It resolve the problem :slight_smile: Hope it will work for you :slight_smile:

I just removed it and then re connected right away. I will try the 24 h method and see if this works.

1 Like

I was not too patient, I tested it now and it worked, so problem solved. Thanks for the help and support guys <3

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.