Watcher Items still can't be placed or created

I play on PC.

The watcher items are in my inventory but I can’t place them and the items do not show up on the crafter station as you know since it hasn’t worked since 3.0 . Is this something that will not be returning to the game or perhaps a oversite when you updating the game with 76gb. I know a bit of snark… still love the game but please fix the watcher items and dragon banners.

They’ve been working fine for me since 3.0, are you certain your Twitch link is active?

Twitch link is just fine. I am not the only one with the problem it was report several times since 3.0. thank you for you the suggestion.

On x box same problem twitch drops are in my skill feat but dont can unlock them

Part of the problem was that it showed as connected when it wasn’t, something about it being expired/corrupted.

Try disconnecting and waiting 24 hours before reconnecting, that fixed it for me last time.

1 Like

I tryed that but was not working

Same here. It’s also doing the same for the new Twitch drops. I’ve reconnected several times, waited weeks, etc… Nothing.

I’ll try it. thank you again.

I reconnected and it worked for me. Thank you kindly.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.