Mod either won't update or game won't recognize it

So Fashionist updated to v2.7.4 just a little while ago. My buddy tried to log into our private server, it told him no, so I rebooted the server. He was then able to log in, no problem. I boot up my PC to go join him, and Steam helpfully downloads the mod update for me. I launch the game…and it says no, my mod version doesn’t match. I have v2.7, it says. I check the Steam update, and sure enough…it downloaded a 0.00 kb file. Super helpful. So I unsubscribe from the mod, wait a bit, relaunch. The game detects the missing mod, downloads it…and says the version doesn’t match. According to Steam, I have the correct version; according to Conan, I have the wrong version. WTAF. Any suggestions?

1 Like

Usually just unsub, then resub will prompt Steam to download the newest version. However private servers usually lag behind a bit (gportal is famous for waiting every 12 hours before doing an auto check for mod downloads). If your server is being hosted by a 3rd party I would suggest that you manually transfer the newest version over to the server via FTP.

Server is successfully updated, as I already stated. My buddy got the update from Steam, and when he tried to log in, got the “mods don’t match” alert. So I restarted the server, and he was able to successfully log in. Ran all the way from Sepermeru to our clan base (roughly the middle of the map), resupply, watch dancers, etc.

When I booted Steam to go join him, it downloaded what I can only assume was an empty file (0.00 kb), though I didn’t see that at the time. I tried to log in, and received an alert that Fashionist was the wrong version (v2.7.0 as opposed to v2.7.4). That was when I investigated Steam and saw the apparently empty file. So I unsubbed & launched the game, trusting in the “autosub” feature. It detected the missing mod, downloaded it…and told me that I had the wrong version. So. Back into Steam, unsub again. Reboot PC. Relaunch Steam. Locate Fashionist, subscribe…and get a 1.3 mb file. (Fashionist’s description says it’s 5.4 mb, btw.) Relaunch the game, doublecheck mods are in the correct order. Mod screen says I have the correct version. Go to access online play…and be told AGAIN that I DO NOT have the correct version.

I’m at my wits’ end here. I literally have no idea how to proceed, short of uninstalling every ■■■■■■■ thing and starting from scratch. It’s clearly not my server; it’s a disagreement between Steam and my PC about which mod version I’m supposed to have.

You could have your buddy send you his pak file since his is working. Or download the one from the server using FTP.

You may also want to verify that another mod didn’t also update around the same time and it being the one to cause the conflict (which you may have already done, I’m just going through the usual steps I always suggest to people).

Well, this has an interesting twist: the game just let me in. Like, seriously. I did nothing differently, no additional steps. I sat for an hour or so, scouring the interwebs, looking for something, ANYTHING. Eventually, I said screw it, lemme just try once more–and bam, it let me in.


I give up. Eff it. I got to play.

Having worked in tech support for ~15 years I’ve encountered this phenomenon many times: something doesn’t work, you wait a bit, then do exactly the same thing again (or get someone else to do exactly the same thing for you) and suddenly it works.

Computers are like that. I hate them.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.