MOD MISMATCH is so infuriating

The game says I have a MOD MISMATCH.

I don’t. I really, really don’t. Hours of work and I know I don’t. I have deleted everything, done a fresh install, let the server install the mods, orginized them in the mod section for it since it’s stupid.

Not only that but it won’t say “X” mod is mismatched, it just makes you check EVERYTHING!

Why can’t like any other game can’t it identify the mod causing a issue and say “Thralls are allive” (or any other mod) doesn’t match. That could be worked with.

And when it comes to running mods I have about 260 on my Skyrim balanced without issue, I have run quite a few on a 7 days server (including one I wrote myself) I know how to balance my mods. I have far less on this is server and so much more headache.

3 Likes

You do!

The game knows you do sadly…

Skyrim is not a client-server game (unless you use that multiplayer mod, in which case you have the exact same scenario - you need to manually make sure each player has the same mod configuration).
You can load all the mods you want without ever seeing a mod mismatch screen in Conan too in Single Player.


So, now that the rants are over, yes there are currently issues with the automated mod updates - they are not happening… workshop updates are not being pushed so every single time any of the mods get an update, you will be presented with a mismatch screen.

There are a number of threads here already if you search for “infinite loop” you will find them, they have workarounds and they also have replies from Funcom staff telling people that they’re aware.

In the meantime though, you need to realize that the automatic update features are the ones that are broken… the game is still able to identify that one or more of the mods doesn’t match the server.

If you have the Steam version then unsubscribing from the mods and doing a verify integrity of game files will also force a workshop update. Before doing that though, just delete your \Mods\modlist.txt as well as \Saved\ModRestartData.json and the servermodlist.txt in your root folder.
After that’s all done and you did your verify integrity… then try joining the server, let it auto-sub you to the mods and redownload them again - if it still fails another verify files will solve it.

Note that the above is the “I don’t know anything about my mods” version…
The smart version is figuring out which mod was updated and just redownloading that… If your game was working yesterday for example… then you go to your steam profile / subscribed item list and simply look at which mod has a new update date… and unsub / resub to that…

If you have the epic games version then you’re downloading mods manually anyway probably with steamcmd or something, in that case just delete the physical files the modlist points to and redownload them…

1 Like

Totally agree with you. Everything was OK with mods before 3.0 and now it’s completely broken. Server side is OK, this bug is on the client side so server admin can’t solve this problem. Players have to do it all by themselves and some of them prefer to leave modded servers and go to unmodded ones instead. It’s a shame - 3 weeks without any patch for this very serious bug.

1 Like

I host a server and we had this issue as well. What you could try is what we do, and it works for all of our players.

The issue we have is if steam is open, or we are playing when a mod update is pushed, steam won’t update it for us. Even if you exit the game and relaunch it. Instead of unsubbing from the mods. Close your game then exit steam. Launch steam, it usually will not start updating mods at this point. Launch Conan until you are in the game menu, not launcher screen. Now exit the game. Then it updates the mods. If you get the mismatch error knowing you have the updated mods, try this too (Don’t attempt to join the server even once before doing these previous steps.) That seems to allow anyone with the correct mod versions to then be able to login too without mismatch error.

~ Cinna

2 Likes

Other multiplayer games solved this particular problem ages ago. (Space engineers and Ark survival evolved for example)

Those games have the server you connect to set the mod version & the mod load order instead of dumping the process onto the end user.

It’s been an old complaint about Funcom’s choice of how they decided to incorporate modding into Conan.

And conan does the exact same thing… if you try to join a server that has mods… Conan will take note of those mods… download them and restart your game automatically to have the same modlist enabled as the server…

So it’s solved… it’s been working for ages… the issue is now when that happens… your computer doesn’t actually get the new files from steam so it just keeps restarting itself in a loop. It’s been working fine prior to 3.0, this situation is temporary… I don’t want to speculate too much but I believe it has to do with them working on something regarding the workshop.

However… it’s really not a big deal… like… this would be one of the lowest priority issues atm… you have to bother with your mods manually for the time being… that’s it, people have been doing that ever since videogame mods were a thing… it’s only now that everything is “automatic”
It’s not difficult or in any way an issue if you stop banging your head against a brick wall and just understand the situation instead of getting frustrated by it…

1 Like

Oh neat, they did finally change it to be server distributed? Apologies it’s been quite some time since touching modded servers due to the old system being… hot garbage.

Not server “distributed” as the mods are not hosted on the server, but hosted on the steam workshop, so more like server-driven. When you try to connect to a modded server the game creates your modlist and automatically subscribes you to them on steam.
From there the steam workshop should push the mod downloads. Atm sadly the part that’s supposed to push updates to already existing mods is being lazy so when people start their games steam doesn’t do an update so they end up trying to connect with different mod versions and getting stuck in update loops. It’s been working pretty well prior to this game update though so hopefully it’ll get back to normal soon!