More missing Crom Coins

Basic Info:
Platform: PlayStation 5
Issue Type: Bazaar
Game Mode: Online Official
Server Type: PvE
Map: Isle of Siptah
Server Name: 8053

Bug Description:
Purchased Crom Coins for $19.99. Playstation processed the transaction, but the coins were not added to my in-game wallet. I read that you are aware of this issue. Is there a plan to deliver our coins that we never received, or should I try to request a refund from Playstation? Maybe coin purchase should be disabled on Playstation until it is fixed to protect people like me, who didn’t know it was an issue until it happened to me.

Bug Reproduction:
Go to bazaar, purchase coins, receive error message that transaction was successful, but coins could not be added to account. Coins were indeed not added to account.

I had the same thing happen. I have heard from others with this issue, and when they try to get a refund from Playstation they are told that they have been delivered so they cannot issue a refund. I am hoping funcom can just get this resolved for everyone. All I want is to be KMart Thor.

Seems it’s happening all over they send you to a ticket page and still nothing gets done

After the last patch this promlem seems more common. I purchased the 20€ package two weeks ago and they where there instant. And are still there after getting the 1200 cc from battlepass back.

I think you need to make a ticket via zendesk. There is a category for bp and bazar.

Beware, they will take a bit to answer (which is fine), and will always ask if you tried shutting down you game and console. I would suggest telling then right away that you have restarted the game & console many times to skip that beginning reply.

Thanks everyone. And thanks for the zendesk link. Mine also worked as intended after the initial 3.0 release and I also still have my 1200 coins from the Battle Pass. I really want the newest armor for the wolf and it costs more than the 1200. I hope funcom can fix this before that armor cycles off!

This is absolutely ridiculous, We pay real money for a product they sell and they didn’t deliver. The only response given is "we are aware of this please send a ticket or an in game report. Problem is there is no option for crom coins on the ingame report. I feel like ive been given the run around…

1 Like

Paid $30 aud and didn’t recieve my coins either. Have restarted and shut down bla bla bla. Have submitted a request too. Trying to get a refund from PS now. Pretty ridiculous

Greetings Exile,

Thank you for reaching out to us. Please submit a ticket to our Help center so our team can investigate what’s happening in your account.

Make sure to select “in-game purchase” as the issue type.

Have a great week!

I have had this issue aswell. Go to the zendesk link and create an account, then above your account icon in the top right press the 3 lines and a blank white box will drop down. Click the center of said box and it will allow you to submit a ticket. Now frim my experience they only reply to you once per day so i would recommend typing in your ticket how you purchased the coins ie…in game or from dashboard. And also supply them with a screen shot of the email confirming your purchase from ps/xbox/steam. It will expedite your claim.

I received my missing Crom coins! Thank you Funcom!!! I followed Lorddank’s instructions from previous post and it worked. Thanks Lorddank!:hugs: I was getting hung up on the in-game Request Help feature that redirected me to the forum, and the forum sent me to zendesk, then the Bazaar box in the zendesk menu told me to use the in-desk Request Help feature. It was a vicious circle. :video_game: I didn’t think I would have to create an account on zendesk, but I did have to. It is different than the forum login so you have to request a new password if you haven’t done a help request before. Then you will get an email and follow the instructions. Then look for the blank white box Lorddank pointed it out and type your need and submit. You will get a confirmation email that your request was received, then another one maybe a day later that says they have added the coins. I signed in to my PS and they were there.:butterfly: I am very pleased with how quickly Funcom fixed this for me. The bug still happens, but I now have what I paid for. I hope this post will be helpful to others.:hibiscus:

1 Like

That’s the problem most people have on the zendesk page. They never will find a way to submit a ticket. You can click the blank place but not everytime it brings you where you want to go.
Switching from mobile mode to desktop mode in your browser could help.

Same here!! Although every time i try to go to the “submit a ticket” i get nowhere! I would really like my coins i paid real money for :sweat_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.