My Archers won't shoot anything (bug?)


#1

Game mode: Private
Problem: | Bug |

I have a problem with my archer thralls - have done since the patch that gave them an inventory, but still ongoing now. Archer thralls that I place simply won’t shoot anything.

I’ve given them arrows in the inventory; enough single arrows to force them to keep the bow given in hand. Arrow has been dragged to the bow and there is an arrow showing on the bow icon in inventory. But they shoot nothing. They occasionally run back on forth on their platform when they have a target, which is an improvement on old behaviour of leaping from the platform to engage in hand-to-hand with no weapons… but still no shooting.

Is this a bug, or am I doing something wrong?


When a game is great value for money..a positive story of my journey so far with CE
#2

Ahh yeah, the blind archers. This is how it was for many many moons. The best way to get these annoying thralls to shoot is to make sure nothing is in front of them (i.e. Crennalted walls, fences, doorways) and to let the monster/player/thrall to hit you while you are infront of them. Or Force the creature to hit your home. (but they might not see that if you placed them to high.) Also they are better at shooting things above them, and on the same level as them, Shooting below them is a 50/50. Welcome to what it means to have blind archers.


#3

These have nothing in front of them and are not placed especially high, nevertheless, they won’t shoot at anything https://steamuserimages-a.akamaihd.net/ugc/918049276007355341/77039F8FC2FD28C5207B1CCD0B80BD537550A8AE/?interpolation=lanczos-none&output-format=jpeg&output-quality=95&fit=inside|1024%3A576&composite-to=,%7C1024%3A576&background-color=black


#4

You broke the archers by filling their inventories.

Basically, if you fill inventories to force them to keep a weapon in hand, they will ‘not’ attack. This is true for all thralls. Leave a slot empty so they can put their weapon away. They will get it out when needed.

Thralls seem to fight best when they have a melee weapon, a ranged weapon and a free space after putting both weapons into their inventories (not equipped). Filling the inventory makes them bug out like crazy during combat.

I think this is because they like switching to their fists for no reason. My follower thrall starts out using her bow, then goes to her fists, then her spear, then randomly switches back to fists, etc. If I don’t leave room for both weapons to be put away, she bugs out when she (presumably) wants to punch stuff.


#5

You’re always naked in your screenshots. You’re going to get skin cancer.


#6

yeah true lol.
it’s a question of … durability, as i have already answered a friend:smile:


#7

Same issue on our server for every player (38 players) The archers won’t shoot but they are running to the gate to engage in mellee


#8

It’s an old thread but wanted to reply to ExNihiloish to say thank you for the fix. Emptying their inventories fixed it. Annoying, as there are threads EVERYWHERE saying “fill their inventories!”.


#9