My game crashes every few minutes and became virtually unplayable

Game mode: [Offline/Co-op online | Singleplayer]
Problem: [Crash | Bug | Performance | Misc]
Region: [United States]

[Good morning,

I am writing this because my game has been crashing since the update for mounts came out. Naturally, I am no longer able to immerse myself in this game due to that, and I am no longer finding the game an enjoyable experience.

I would ask that something be done to fix this issue. I play the xbox one. I own a digital copy of the game. I also play exclusively single player mode. The crashes can occur anywhere. I’ve crashed in various biomes and don’t own bases in all of them. At first I thought that it may be because of the size of my main base in the highlands…which is adjacent from the entrance to New Asgarath. That base is very large in design, width wise…not so much height wise, though it’s still a large and looming structure. Still, since I play on what is effectively sandbox mode, I expect this game to be able to handle that…and it did, until the update came out.

I want to point out that this crash has also happened in the jungle biome where I have no base.

Its occurred in the desert where my base was a smile island that didn’t even have shelter.

It’s occurred in the desert by the oasis… My first actual base.

It’s occurred on the border of the highlands and the snow capped mountains… My northern fortress.

It’s occurred atop the snow capped mountains…where I wanted to build a base far from everything in the hopes of not crashing.

It’s occurred just running from point a to point b.

The issue is game breaking because I cannot build, gather, level up thralls, take thralls, etc…without worrying the game will crash. I’ve had named thralls unconscious and being dragged…only to have the game crash before they make it to the wheel of pain. When I restart, naturally the unconscious named thrall is no longer there and more than likely, its a generic thrall once again.

I noticed that others were having this issue before, so I waited to play it again until you had done something about it. The hotfix was meant to address this to my understanding. However, for me it’s still ongoing. Please fix this. Thank you for your time and consideration. ]

Steps on how to reproduce issue:

  1. log in
  2. Wait for the game to load. (Approximately 5 mins.)
  3. Play the game.
  4. Crash or freeze after 5 to 20 minutes of playing the game.
1 Like

Hello @Swordmaster757, welcome to the community!

We’d appreciate if you could share some additional details so that we can relay this information to our team:

Which XBox model do you have?

Do you have your game installed to an SSD or HDD?

Is the console stable playing other demanding games?

Have you tried to reset the console cache or reinstall the game?

Good morning, and thank you for the welcoming.

I own the original model of the Xbox.

I believe that its installed to my terabyte drive due to the size of the game, but I am unsure to be perfectly honest.

My system is stable playing all other games.

I have not attempted to reinstall the game as of yet.
(I do not know how to reset the console cache.)

Thank you for your reply also.

Try too start first singelplayer but use the offline option (x button )wait till its loaded up then walk a coupel steps quite to main menue and then go to online and search for your server and load it up

1 Like

Oh and reseting system cache on x box hold long the button on your x box till it shut down after this you get a llonger restart of your x box whit a green loading screen

I only play offline and co op modes (when I’m playing with one of my friends.) I haven’t tried the official servers nor private servers yet. I like the base building sandbox type in the offline game.

I will try to reset it like that and see if it works. Thank you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.