New Server Rental - Where do I go after Selecting Rent Server

New Server Rental - Where do I go after Selecting Rent Server
Game mode: Online
Problem: Misc
Region: America

We waited until the final release to rent a server. I have installed the Final Release Update and restarted the console.

When I go to Rent Server to rent a new server, I get the following message.

The server rental system has been updated, please rent new servers or migrate old ones to the new system by getting gportal application. Any remaining tokens can still be used as before.

What am I supposed to do or where am I supposed to go to rent the new server since there is no option to select new server on the xbox? The screen shows (A) Select, (B) Back, (RB) Go to Xbox Store. There is nothing to select using the (A) button.

Please follow this link for the GPORTAL application.


I downloaded the app, set up an account, and purchased a server.

I am waiting for it to finish setting up as an active server. Although it says it could take up to 3 minutes, it has been closer to 30 to 40 minutes and it still has not finished, but I attribute that to everyone rushing to set up or convert their servers.


Server never set up, but I was charged. How do I set up my server without being charged again?

I’m glad it appears to have worked for you. Your best bet is to contact GPORTAL for any further questions about your server. We’re all getting slammed pretty hard right now (which is exciting!) but I hope things come up quickly for you. :slight_smile:

Funcom doesn’t care man, I have been trying to play on the 40 slot server I purchased since launch. I can get no help and no support from anywhere. Just hey tough luck thanks for the money though. Brush off from both funcom and gportal. How sad have over a dozen people waiting to play… Supported and played early access… But tough luck for me huh.

I fully understand that Funcom is getting slammed with the Official Release. If I did not love playing the game so much I would not care about getting into the game. Contacted G-Portal and the issue is still not resolved. They see my server, but I do not. Fingers-crossed on a fast resolution.

Hi, tried 2 times to rent and same here, never worked and microsoft even charged me 2 times. Hopefully I called them and they refunded me. Now I will contact G-portal to ask wadafak is happening ^^’

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.